meta-openembedded: subtree update:ea8604a0e3..d0748372d2
Adrian Bunk (1):
libnih: Remove
Alexander Kanavin (3):
sysprof: add a recipe from oe-core
sysprof: update to 3.34.1
sysprof: fix ARM builds
Andreas Müller (2):
evolution-data-server: remove pythonnative from inherit
fontforge: rework for python3
Diego Rondini (2):
cups-filters: use libexecdir and cleanup
cups-filters: upgrade 1.26.0 -> 1.26.2
Gianfranco Costamagna (2):
websocketpp: refresh clang patch
vboxguestdrivers: update to new version 6.1.2
Khem Raj (14):
sysprof: avoid namesapace conflict with glibc headers
jack: Use c++ compiler for programs which use c++ source files
iozone3: Do not define prototype for pread64()
libhugetlbfs: Fix missing file mode in create() API
rdma-core: Use overloadable attribute with clang
sysprof: Correct systemdunitdir location
opencv: Tend for the compiler --param option rename in gcc10
grpc: Link with libatomic on powerpc
ssiapi: Needs boost/ppc support
fluentbit: Fix build on powerpc
mozjs: extend --with-intl-api=build to ppc
mpv: Disable lua support on powerpc
packagegroup-meta-oe: Remove unbuildable recipes for ppc64le from rdeps
opensc: Upgrade to 0.20.0
Mingde (Matthew) Zeng (2):
byacc: upgrade 20191103 -> 20191125
keyutils: upgrade 1.6 -> 1.6.1
Peter Kjellerstedt (1):
gitpkgv.bbclass: Add support for extending the supported tag formats
S. Lockwood-Childs (1):
lcov: geninfo needs another perl module
Wang Mingyu (15):
python3-cheetah: upgrade 3.2.3 -> 3.2.4
python3-coverage: 4.4.2 -> 5.0.2
python3-keras-applications: upgrade 1.0.6 -> 1.0.8
python3-keras-preprocessing: upgrade 1.0.5 -> 1.1.0
python3-more-itertools: 7.2.0 -> 8.1.0
python3-multidict: 4.5.2 -> 4.7.4
python3-ordered-set: 3.0.1 -> 3.1.1
python3-pulsectl: upgrade 18.12.5 -> 20.1.2
python-cmd2: upgrade 0.9.22 -> 0.9.23
python-engineio: upgrade 3.11.1 -> 3.11.2
python-javaobj-py3: upgrade 0.3.0 -> 0.4.0.1
python-kconfiglib: upgrade 10.42.0 -> 13.7.0
python-packaging: 19.2 -> 20.0
python-periphery: 2.0.0 -> 2.0.1
python-pyrsistent: upgrade 0.15.5 -> 0.15.7
William A. Kennington III via Openembedded-devel (1):
cppzmq: bump to version 4.6.0
Yi Zhao (3):
crda: fix UDEV_RULE_DIR
open-vm-tools: fix build error with usrmerge feature
multipath-tools: fix libudevdir
Zang Ruochen (14):
dhcpcd: upgrade 8.1.1 -> 8.1.5
fio: upgrade 3.16 -> 3.17
libencode-perl: upgrade 3.01 -> 3.02
zabbix: modify service file
libmicrohttpd: upgrade 0.9.68 -> 0.9.69
libsass: upgrade 3.6.1 -> 3.6.3
pcsc-lite: upgrade 1.8.25 -> 1.8.26
python3-yarl: upgrade 1.3.0 -> 1.4.2
python3-wheel: upgrade 0.32.3 -> 0.33.6
python3-websockets: upgrade 8.0.2 -> 8.1
python-wcwidth: upgrade 0.1.7 -> 0.1.8
python-waitress: upgrade 1.4.1 -> 1.4.2
python-tqdm: upgrade 4.38.0 -> 4.41.1
python-supervisor: upgrade 4.0.2 -> 4.1.0
Change-Id: I2c394941fc3140bfeadcec3542cd72892fdcda6e
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.26.bb b/meta-openembedded/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.26.bb
new file mode 100644
index 0000000..5e60846
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.26.bb
@@ -0,0 +1,55 @@
+SUMMARY = "PC/SC Lite smart card framework and applications"
+HOMEPAGE = "http://pcsclite.alioth.debian.org/"
+LICENSE = "BSD & GPLv3+"
+LICENSE_${PN} = "BSD"
+LICENSE_${PN}-lib = "BSD"
+LICENSE_${PN}-doc = "BSD"
+LICENSE_${PN}-dev = "BSD"
+LICENSE_${PN}-dbg = "BSD & GPLv3+"
+LICENSE_${PN}-spy = "GPLv3+"
+LICENSE_${PN}-spy-dev = "GPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=628c01ba985ecfa21677f5ee2d5202f6"
+
+SRC_URI = "https://pcsclite.apdu.fr/files/${BP}.tar.bz2"
+SRC_URI[md5sum] = "9d36882998449daceec267c68a21ff0d"
+SRC_URI[sha256sum] = "3eb7be7d6ef618c0a444316cf5c1f2f9d7227aedba7a192f389fe3e7c0dfbbd9"
+
+inherit autotools systemd pkgconfig
+
+EXTRA_OECONF = " \
+ --disable-libusb \
+ --enable-usbdropdir=${libdir}/pcsc/drivers \
+"
+
+S = "${WORKDIR}/pcsc-lite-${PV}"
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} udev"
+PACKAGECONFIG_class-native ??= ""
+
+PACKAGECONFIG[systemd] = ",--disable-libsystemd,systemd,"
+PACKAGECONFIG[udev] = "--enable-libudev,--disable-libudev,udev"
+
+PACKAGES = "${PN} ${PN}-dbg ${PN}-dev ${PN}-lib ${PN}-doc ${PN}-spy ${PN}-spy-dev"
+
+RRECOMMENDS_${PN} = "ccid"
+RRECOMMENDS_${PN}_class-native = ""
+
+FILES_${PN} = "${sbindir}/pcscd"
+FILES_${PN}-lib = "${libdir}/libpcsclite*${SOLIBS}"
+FILES_${PN}-dev = "${includedir} \
+ ${libdir}/pkgconfig \
+ ${libdir}/libpcsclite.la \
+ ${libdir}/libpcsclite.so"
+
+FILES_${PN}-spy = "${bindir}/pcsc-spy \
+ ${libdir}/libpcscspy*${SOLIBS}"
+FILES_${PN}-spy-dev = "${libdir}/libpcscspy.la \
+ ${libdir}/libpcscspy.so "
+
+RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
+SYSTEMD_SERVICE_${PN} = "pcscd.socket"
+RDEPENDS_${PN}-spy +="python"
+
+BBCLASSEXTEND = "native"