meta-fii/meta-kudo: Add kudo-cmd a collection of kudo system utils

1. Add Kudo.sh, a script for display and controlling kudo system
2. Add kudo-ras.sh for debug Ampere system errors on kudo system

Signed-off-by: XP Chen <xiao-peng.chen@fii-na.com>
Change-Id: I5763e0de4be942b9b851b910448d15135ca9db16
Signed-off-by: Mohaimen Alsamarai <mohaimen.alsamarai@fii-na.com>
diff --git a/meta-fii/meta-kudo/recipes-kudo/kudo-sys-utility/kudo-cmd.bb b/meta-fii/meta-kudo/recipes-kudo/kudo-sys-utility/kudo-cmd.bb
new file mode 100644
index 0000000..777fa6f
--- /dev/null
+++ b/meta-fii/meta-kudo/recipes-kudo/kudo-sys-utility/kudo-cmd.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Phosphor OpenBMC Kudo System Command"
+DESCRIPTION = "Phosphor OpenBMC Kudo System Command Daemon"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:
+
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+RDEPENDS_${PN} += "bash"
+
+SRC_URI = " \
+    file://kudo.sh \
+    file://kudo-ras.sh \
+    "
+
+SYSTEMD_PACKAGES = "${PN}"
+
+do_install () {
+    install -d ${D}/${sbindir}
+    install -m 0755 ${WORKDIR}/kudo.sh ${D}/${sbindir}/kudo.sh
+    install -m 0755 ${WORKDIR}/kudo-ras.sh ${D}/${sbindir}/kudo-ras.sh
+}