meta-raspberrypi: subtree update:a7cc636d4e..f5fe02c30c

Aaron Shaw (5):
      overlays: reorder in alphabetical order
      overlays: add justboom overlays
      overlays: add overlay to allow 64 bit usage with CM3
      overlays: add overlays for pi 400 and cm4
      overlays: add missing device overlays

Aurelian Zanoschi (2):
      rpi-config: Add support for CM4 host USB
      [documentation]Add USB host support in documentation

Bartłomiej Burdukiewicz (1):
      rpi-cmdline: remove unnecessary spaces from cmdline.txt

Christopher Clark (1):
      machine: use weak default for kernel and KERNEL_DEVICETREE settings

Jonas Vautherin (1):
      linux-raspberrypi: Superfluous 'inherit kernel'

Martin Jansa (6):
      rpi-config: fix do_deploy
      rpi-config: use CONFIG shell variable
      linux-raspberrypi: add recipe for 5.10 version
      linux-raspberrypi: update LIC_FILES_CHKSUM in .inc file and drop from 5.10 and dev recipe
      rpi-default-versions: Switch default kernel to 5.10
      raspberrypi-firmware.inc: upgrade to latest for 5.10.13 kernel

Matt Spencer (1):
      linux-raspberrypi: Enable use of 'RPI_EXTRA_CONFIG += ...' in local.conf

Ovidiu Panait (1):
      linux-raspberrypi: pass dtc flags via KERNEL_DTC_FLAGS

Paul Barker (5):
      conf: Use unified u-boot config for 64-bit targets
      raspberrypi4-64: No need to force arm_64bit=1
      linux-raspberrypi: Uprev to v5.4.83
      linux-raspberrypi: Uprev yocto-kernel-cache
      kas-poky-rpi.yml: Make git ignore layers cloned by kas

SCVready (1):
      rpi-config: Relocated "start_x=1" in config.txt

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: Ie1a8cd049694b5f3158b63cedc30c9df24f82120
diff --git a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
index 1d04c2f..ba97ed5 100644
--- a/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
+++ b/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_5.4.bb
@@ -1,8 +1,8 @@
-LINUX_VERSION ?= "5.4.79"
+LINUX_VERSION ?= "5.4.83"
 LINUX_RPI_BRANCH ?= "rpi-5.4.y"
 
-SRCREV_machine = "9797f1a4938c20139b00a25de93cc99efb5c291b"
-SRCREV_meta = "5d52d9eea95fa09d404053360c2351b2b91b323b"
+SRCREV_machine = "08ae2dd9e7dc89c20bff823a3ef045de09bfd090"
+SRCREV_meta = "d676bf5ff7b7071e14f44498d2482c0a596f14cd"
 
 KMETA = "kernel-meta"
 
@@ -19,4 +19,4 @@
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
 
-KERNEL_EXTRA_ARGS += "DTC_FLAGS='-@ -H epapr'"
+KERNEL_DTC_FLAGS += "-@ -H epapr"