meta-raspberrypi: subtree update:3a1fec22c0..4b89f63699

Aaron Shaw (1):
      linux-firmware-rpidistro: Added firmware for BCM43456

Khem Raj (3):
      mesa-gl: Enable swrast dri backend for rpi/userland
      userland: Fix weston build with userland graphics
      libglu: Fix build with userland graphics

Tobias Off (1):
      linux-firmware-rpidistro: Missing link to firmware causes wifi not working on raspberrypi zero w

Trevor Woerner (1):
      userland: fix invalid packageconfig

Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I06d2fbef19f827ffcbb485c60935b9a8c373e1c4
diff --git a/meta-raspberrypi/recipes-graphics/mesa/mesa-gl_%.bbappend b/meta-raspberrypi/recipes-graphics/mesa/mesa-gl_%.bbappend
index 08ec1c5..84cd479 100644
--- a/meta-raspberrypi/recipes-graphics/mesa/mesa-gl_%.bbappend
+++ b/meta-raspberrypi/recipes-graphics/mesa/mesa-gl_%.bbappend
@@ -1,6 +1,8 @@
 PACKAGECONFIG_append_rpi = " gbm"
 PROVIDES_append_rpi = " virtual/libgbm"
 
+DRIDRIVERS_append_rpi = ",swrast"
+
 do_install_append_rpi() {
     rm -rf ${D}${includedir}/KHR/khrplatform.h
 }