meta-phosphor: prep for new override syntax
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I588025b614416c43aa2d053765ab53bacf890cb5
diff --git a/meta-phosphor/recipes-phosphor/certificate/phosphor-bmcweb-cert-config.bb b/meta-phosphor/recipes-phosphor/certificate/phosphor-bmcweb-cert-config.bb
index 9fa5f3a..1d9f5a3 100644
--- a/meta-phosphor/recipes-phosphor/certificate/phosphor-bmcweb-cert-config.bb
+++ b/meta-phosphor/recipes-phosphor/certificate/phosphor-bmcweb-cert-config.bb
@@ -5,26 +5,26 @@
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-RDEPENDS_${PN} = "phosphor-certificate-manager"
+RDEPENDS:${PN} = "phosphor-certificate-manager"
inherit allarch
SRC_URI = "file://env"
-FILES_${PN} = "${datadir}"
+FILES:${PN} = "${datadir}"
do_install() {
install -D ${WORKDIR}/env ${D}/${datadir}/phosphor-certificate-manager/bmcweb
}
-pkg_postinst_${PN}() {
+pkg_postinst:${PN}() {
LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@bmcweb.service"
TARGET="../phosphor-certificate-manager@.service"
mkdir -p $D$systemd_system_unitdir/multi-user.target.wants
ln -s $TARGET $LINK
}
-pkg_prerm_${PN}() {
+pkg_prerm:${PN}() {
LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@bmcweb.service"
rm $LINK
}