meta-quanta: gbs: install some missing useful packages
ipmitool:
- debug/manufacturing purpose
phosphor-user-manager:
- basic authenication for Refish
phosphor-nslcd-authority-cert-config:
- be able to install your owned CA certificate
for Redfish
Signed-off-by: George Hung <george.hung@quantatw.com>
Change-Id: I8697fe674d58268dbe348c9374f7de32037041c1
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/images/obmc-phosphor-image.bbappend b/meta-quanta/meta-gbs/recipes-phosphor/images/obmc-phosphor-image.bbappend
index effbcc1..00d2dba 100644
--- a/meta-quanta/meta-gbs/recipes-phosphor/images/obmc-phosphor-image.bbappend
+++ b/meta-quanta/meta-gbs/recipes-phosphor/images/obmc-phosphor-image.bbappend
@@ -20,6 +20,7 @@
OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " phosphor-virtual-sensor"
OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " acpi-power-state-daemon"
OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " virtual/obmc-gpio-presence"
+OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " ipmitool"
# Add back packages that were part of packagegroup-obmc-apps-extras
OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " phosphor-hwmon"
@@ -27,6 +28,8 @@
# Required for obmc-bmcweb
OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " bmcweb"
OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " phosphor-bmcweb-cert-config"
+OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " phosphor-nslcd-authority-cert-config"
+OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " phosphor-user-manager"
# Required for LEDs. Part of obmc-leds
OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " ${VIRTUAL-RUNTIME_obmc-leds-manager}"
OBMC_IMAGE_EXTRA_INSTALL_append_gbs = " ${VIRTUAL-RUNTIME_obmc-leds-sysfs}"