meta-ethanolx: Add PID control for fans
Add support for dynamic fan RPM control based on the values from
temperature sensors.
Control is based on PIDs and is splitted to 3 thermal zones:
Zone 1:
- CPU0 SB-TSI temp with a setpoint 60.0 C
- P0 FAN
Zone 2:
- CPU1 SB-TSI temp with a setpoint 60.0 C
- P1 FAN
Zone 3:
- All LM75A sensors on board with a setpoint 35.0 C
- SYS FAN1 - SYS FAN6
Signed-off-by: Konstantin Aladyshev <aladyshev22@gmail.com>
Change-Id: Ifca359ba23777e2b1f46783272cf98ff0b08fe68
diff --git a/meta-amd/recipes-phosphor/fans/phosphor-pid-control_%.bbappend b/meta-amd/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
index 4cdfe5a..6e528dc 100644
--- a/meta-amd/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
+++ b/meta-amd/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
@@ -1,3 +1,5 @@
FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-EXTRA_OECONF:append = " --enable-configure-dbus=yes"
+inherit obmc-phosphor-systemd
+
+SYSTEMD_SERVICE:${PN} = "phosphor-pid-control.service"