meta-quanta: gbs: update bmcweb build option
- update to use meson instead of cmake
- change http request body limit size to 40MB
to pass firmware update of Robot framework
test for GBS
- create /var/lib/bmcweb folder to satisfy the
path redfish eventservice required to save
config and subscriptions
Signed-off-by: George Hung <george.hung@quantatw.com>
Change-Id: Ic0de91547d11aad9cc6412a389d26c2da5c79644
diff --git a/meta-quanta/meta-gbs/recipes-phosphor/interfaces/bmcweb_%.bbappend b/meta-quanta/meta-gbs/recipes-phosphor/interfaces/bmcweb_%.bbappend
index 87ecf4f..2c19a3e 100755
--- a/meta-quanta/meta-gbs/recipes-phosphor/interfaces/bmcweb_%.bbappend
+++ b/meta-quanta/meta-gbs/recipes-phosphor/interfaces/bmcweb_%.bbappend
@@ -1,3 +1,8 @@
-EXTRA_OECMAKE_append_gbs = " \
- -DBMCWEB_ENABLE_REDFISH_DBUS_LOG_ENTRIES=ON \
+EXTRA_OEMESON_append_gbs = " \
+ -Dredfish-dbus-log=enabled \
+ -Dhttp-body-limit=40 \
"
+
+do_install_append_gbs(){
+ install -d ${D}${localstatedir}/lib/bmcweb
+}