meta-raspberrypi: refresh thud: d5d92f2cb7..c71d79efc5
Update meta-raspberrypi to thud HEAD.
Andrei Gherzan (2):
raspberrypi-cm3.conf: Define it as a stand alone machine
docs/layer-contents.md: raspberrypi-cm3 is a stand alone machine now
Drew Moseley (1):
linux-raspberrypi: Update to 4.14.85
Hugo Hromic (1):
docs: improve the contributing section
Khem Raj (8):
dynamic-layers/qt5-layer: Append to oe-device-extra.pri instead of rewriting
bpftool: Disable for rpi until kernel is not > 4.14
packagegroup-meta-oe.bbappend: remove bpftool for rpi
Add meta-oe to dynamic-layers
layer.conf: Fix typo for openembedded-layer dynamic layer addition
bpftool: Move under meta-oe dynamic layer
qtbase: Get eglfs/kms working with vc4graphics
userland: Use original name libegl-mesa in rdeps
Marek Belisko (1):
devtools: Added raspi-gpio
Ming Liu (2):
rpi-default-providers.inc: use virtual/libgbm instead of libgbm
userland: do not provide libgl1
Pepijn de Vos (2):
firmware.inc: Update to 20181211
linux-raspberrypi: Update to 4.14.87
Ricardo Salveti (1):
bluez-firmware-rpidistro: update bluez-firmware
Richard Osterloh (1):
sdcard_image-rpi: Format boot partition as FAT32
Zahari Petkov (2):
linux-raspberrypi: Update to 4.14.98
firmware.inc: Update to 20190212
memox_5 (1):
rpi-config: used printf to escape properly
Change-Id: I36c776929c0ca91f06ab0f9bd93f1e2ce19cdf8b
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-raspberrypi/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/meta-raspberrypi/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index 7d6ab84..58b7b47 100644
--- a/meta-raspberrypi/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/meta-raspberrypi/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -1,17 +1,17 @@
PACKAGECONFIG_GL_rpi = "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'gl', \
- bb.utils.contains('DISTRO_FEATURES', 'opengl', 'eglfs gles2 linuxfb', \
+ bb.utils.contains('DISTRO_FEATURES', 'opengl', 'eglfs gles2', \
'', d), d)}"
-#PACKAGECONFIG_GL_rpi = "${@bb.utils.any_distro_features('x11 wayland', '', 'eglfs', d)}"
+PACKAGECONFIG_GL_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', ' gbm kms', '', d)}"
PACKAGECONFIG_FONTS_rpi = "fontconfig"
PACKAGECONFIG_append_rpi = " libinput examples tslib xkb xkbcommon-evdev"
PACKAGECONFIG_remove_rpi = "tests"
-OE_QTBASE_EGLFS_DEVICE_INTEGRATION_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', 'eglfs_kms', 'eglfs_brcm', d)}"
+OE_QTBASE_EGLFS_DEVICE_INTEGRATION_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', 'eglfs_brcm', d)}"
do_configure_prepend_rpi() {
# Add the appropriate EGLFS_DEVICE_INTEGRATION
if [ "${@d.getVar('OE_QTBASE_EGLFS_DEVICE_INTEGRATION')}" != "" ]; then
- echo "EGLFS_DEVICE_INTEGRATION = ${OE_QTBASE_EGLFS_DEVICE_INTEGRATION}" > ${S}/mkspecs/oe-device-extra.pri
+ echo "EGLFS_DEVICE_INTEGRATION = ${OE_QTBASE_EGLFS_DEVICE_INTEGRATION}" >> ${S}/mkspecs/oe-device-extra.pri
fi
}
RDEPENDS_${PN}_append_rpi = " userland"