Default channel config JSON data
Added default configuration JSON files for all
channel information, includes
1) Channel common config
2) Channel access (volatile & non-volatile) data
(From meta-phosphor rev: 549a76fc7a8e3cb0b3d84515397aa9c03786204f)
Change-Id: Iad077e389fea41cd1d0bf02cef781c8314e6fcae
Signed-off-by: AppaRao Puli <apparao.puli@intel.com>
Signed-off-by: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
index 2cba63d..96e977c 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
@@ -11,6 +11,8 @@
file://dcmi_sensors.json \
file://dev_id.json \
file://power_reading.json \
+ file://channel_access.json \
+ file://channel_config.json \
"
FILES_${PN} = " \
@@ -19,6 +21,8 @@
${datadir}/ipmi-providers/dcmi_sensors.json \
${datadir}/ipmi-providers/dev_id.json \
${datadir}/ipmi-providers/power_reading.json \
+ ${datadir}/ipmi-providers/channel_access.json \
+ ${datadir}/ipmi-providers/channel_config.json \
"
do_fetch[noexec] = "1"
@@ -38,4 +42,9 @@
${D}${datadir}/ipmi-providers/dev_id.json
install -m 0644 -D ${WORKDIR}/power_reading.json \
${D}${datadir}/ipmi-providers/power_reading.json
+ install -m 0644 -D ${WORKDIR}/channel_access.json \
+ ${D}${datadir}/ipmi-providers/channel_access.json
+ install -m 0644 -D ${WORKDIR}/channel_config.json \
+ ${D}${datadir}/ipmi-providers/channel_config.json
+
}