meta-openembedded: subtree update:55de2d06ad..53d431639a

Adrian Bunk (1):
      ltrace: Remove RDEPENDS on elfutils

Andreas Müller (22):
      gedit: upgrade 2.30.4 -> 3.34.0
      gtksourceview2: remove
      evolution-data-server: give up fine grained -dev/-dbg packages
      evolution-data-server: upgrade 3.26.6 -> 3.34.1 and rework
      gnome-font-viewer: initial add 3.34.0
      evince: upgrade 3.28.2 -> 3.34.1
      file-roller: inital add 3.32.2
      gexiv2: initial add 0.12.0
      gnome-autoar: inital add 0.2.3
      tracker: initial add 2.3.1
      nautilus: upgrade 3.18.5 -> 3.34.1
      geocode-glib: initial add 3.26.1
      libgweather: initial add 3.34.0
      libwacom: initial add 0.33
      gnome-settings-daemon: initial add 3.34.1
      fluidsynth: upgrade 2.0.7 -> 2.0.9
      gnome-terminal: re-add 3.34.2
      gnome-terminal: Fix build for musl
      gmime: cleanup recipe
      gmime: move to meta-oe/recipes-gnome
      gmime: upgrade 3.2.4 -> 3.2.5
      evolution-data-server: add upstream-version-is-even & gsettings to inherit

Bartosz Golaszewski (1):
      libgpiod: put gpio utils into an actual separate package

Gaylord Charles (1):
      nginx: fix install paths

Khem Raj (11):
      evince: Fix build with clang
      poppler: Extend the c/c++ flags fix to cover clang
      pidgin-sipe: Fix another case of struct incompatiblility due to 64bit time_t
      gperftools: Convert static and libunwind support to packageconfig
      libmad: Define O2 for all arches as default optimization
      rsyslog: Dont force enable atomic builtins on mips
      libtorrent: Drop 64bit atomics patch for mips/ppc
      libtorrent: Disable instrumentation on ppc/mips
      libkcapi: Move static inline functions where used
      grpc: Link with libatomic on clang/x86
      upm: Link with libatomic on clang/x86

Leon Anavi (1):
      surf: Add a simple web browser

Martin Balik (1):
      squid: upgrade 4.6 -> 4.9

Nicola Lunghi (2):
      python-jsonschema: multiple fixes
      python-jsonschema: add PACKAGECONFIG nongpl option

Oleksandr Kravchuk (1):
      flatbuffers: update to 1.11.0

Peter Kjellerstedt (1):
      libldb: Do not require the "pam" distro feature to be enabled

nick83ola (2):
      python3-apply-defaults: add recipe
      python3-jsonrpcserver: add recipe

Change-Id: I231fc015cba86b7c14915ffc3f6f123c9296fd68
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb b/meta-openembedded/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb
new file mode 100644
index 0000000..82160b1
--- /dev/null
+++ b/meta-openembedded/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb
@@ -0,0 +1,70 @@
+require ${BPN}.inc
+
+DEPENDS = " \
+    ${BPN}-native intltool-native gperf-native \
+    glib-2.0 gtk+3 libgdata \
+    dbus db virtual/libiconv zlib libsoup-2.4 libical nss libsecret \
+"
+
+inherit gsettings gobject-introspection distro_features_check cmake gtk-doc gettext perlnative pythonnative
+
+REQUIRED_DISTRO_FEATURES = "x11"
+
+SRC_URI += " \
+    file://0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch \
+    file://0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch \
+    file://0003-contact-Replace-the-Novell-sample-contact-with-somet.patch \
+    file://0004-call-native-helpers.patch \
+    file://iconv-detect.h \
+"
+
+LKSTRFTIME = "HAVE_LKSTRFTIME=ON"
+LKSTRFTIME_libc-musl = "HAVE_LKSTRFTIME=OFF"
+
+# For arm qemu-arm runs at 100% CPU load and never returns - so disable introspection for now
+GI_DATA_ENABLED="False"
+
+EXTRA_OECMAKE = " \
+    -DSYSCONF_INSTALL_DIR=${sysconfdir} \
+    -DWITH_KRB5=OFF \
+    -DENABLE_GOA=OFF \
+    -DENABLE_UOA=OFF \
+    -DENABLE_GOOGLE_AUTH=OFF \
+    -DENABLE_WEATHER=OFF \
+    -DENABLE_INTROSPECTION=${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'ON', 'OFF', d)} \
+    -D${LKSTRFTIME} \
+    -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
+"
+
+PACKAGECONFIG[canberra] = "-DENABLE_CANBERRA=ON,-DENABLE_CANBERRA=OFF,libcanberra"
+PACKAGECONFIG[oauth]    = "-DENABLE_OAUTH2=ON,-DENABLE_OAUTH2=OFF,webkitgtk json-glib"
+
+# BROKEN: due missing pkg-config in openldap eds' cmake finds host-libs when
+# searching for openldap-libs
+PACKAGECONFIG[openldap] = "-DWITH_OPENLDAP=ON,-DWITH_OPENLDAP=OFF,openldap"
+
+# -ldb needs this on some platforms
+LDFLAGS += "-lpthread -lgmodule-2.0 -lgthread-2.0"
+
+do_configure_append () {
+    cp ${WORKDIR}/iconv-detect.h ${S}/src
+
+    # fix native perl shebang
+    sed -i 's:${STAGING_BINDIR_NATIVE}/perl-native:${bindir}:' ${B}/src/tools/addressbook-export/csv2vcard
+
+    # fix abs path for g-ir-scanner-wrapper
+    sed  -i ${B}/build.ninja \
+        -e 's: ${bindir}/g-ir-scanner-wrapper: ${STAGING_BINDIR}/g-ir-scanner-wrapper:g'
+}
+
+do_compile_prepend() {
+    export GIR_EXTRA_LIBS_PATH="${B}/camel/.libs:${B}/libedataserver/.libs"
+}
+
+FILES_${PN} =+ " \
+    ${datadir}/dbus-1 \
+    ${datadir}/evolution-data-server-*/ui/ \
+    ${systemd_user_unitdir} \
+"
+
+RDEPENDS_${PN} += "perl"