meta-openembedded: subtree update:55de2d06ad..53d431639a
Adrian Bunk (1):
ltrace: Remove RDEPENDS on elfutils
Andreas Müller (22):
gedit: upgrade 2.30.4 -> 3.34.0
gtksourceview2: remove
evolution-data-server: give up fine grained -dev/-dbg packages
evolution-data-server: upgrade 3.26.6 -> 3.34.1 and rework
gnome-font-viewer: initial add 3.34.0
evince: upgrade 3.28.2 -> 3.34.1
file-roller: inital add 3.32.2
gexiv2: initial add 0.12.0
gnome-autoar: inital add 0.2.3
tracker: initial add 2.3.1
nautilus: upgrade 3.18.5 -> 3.34.1
geocode-glib: initial add 3.26.1
libgweather: initial add 3.34.0
libwacom: initial add 0.33
gnome-settings-daemon: initial add 3.34.1
fluidsynth: upgrade 2.0.7 -> 2.0.9
gnome-terminal: re-add 3.34.2
gnome-terminal: Fix build for musl
gmime: cleanup recipe
gmime: move to meta-oe/recipes-gnome
gmime: upgrade 3.2.4 -> 3.2.5
evolution-data-server: add upstream-version-is-even & gsettings to inherit
Bartosz Golaszewski (1):
libgpiod: put gpio utils into an actual separate package
Gaylord Charles (1):
nginx: fix install paths
Khem Raj (11):
evince: Fix build with clang
poppler: Extend the c/c++ flags fix to cover clang
pidgin-sipe: Fix another case of struct incompatiblility due to 64bit time_t
gperftools: Convert static and libunwind support to packageconfig
libmad: Define O2 for all arches as default optimization
rsyslog: Dont force enable atomic builtins on mips
libtorrent: Drop 64bit atomics patch for mips/ppc
libtorrent: Disable instrumentation on ppc/mips
libkcapi: Move static inline functions where used
grpc: Link with libatomic on clang/x86
upm: Link with libatomic on clang/x86
Leon Anavi (1):
surf: Add a simple web browser
Martin Balik (1):
squid: upgrade 4.6 -> 4.9
Nicola Lunghi (2):
python-jsonschema: multiple fixes
python-jsonschema: add PACKAGECONFIG nongpl option
Oleksandr Kravchuk (1):
flatbuffers: update to 1.11.0
Peter Kjellerstedt (1):
libldb: Do not require the "pam" distro feature to be enabled
nick83ola (2):
python3-apply-defaults: add recipe
python3-jsonrpcserver: add recipe
Change-Id: I231fc015cba86b7c14915ffc3f6f123c9296fd68
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_3.34.1.bb b/meta-openembedded/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_3.34.1.bb
new file mode 100644
index 0000000..d6af7a7
--- /dev/null
+++ b/meta-openembedded/meta-gnome/recipes-gnome/gnome-settings-daemon/gnome-settings-daemon_3.34.1.bb
@@ -0,0 +1,59 @@
+SUMMARY = "Window navigation construction toolkit"
+LICENSE = "LGPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
+
+GNOMEBASEBUILDCLASS = "meson"
+
+inherit gnomebase gobject-introspection gettext distro_features_check upstream-version-is-even
+
+SRC_URI[archive.md5sum] = "528b0b7cc2dd22c6026a9c8739c71fa7"
+SRC_URI[archive.sha256sum] = "7ce4979817866911a94ecb75b36db56797e038c0c524c5c1a81aefccafc17337"
+
+DEPENDS = " \
+ colord \
+ geocode-glib \
+ gcr \
+ gnome-desktop3 \
+ libgweather \
+ lcms \
+ libcanberra \
+ geoclue \
+ libnotify \
+ upower \
+ libwacom \
+ virtual/libx11 \
+"
+
+# all these are mandatory
+REQUIRED_DISTRO_FEATURES = "x11 polkit pulseaudio systemd gobject-introspection-data"
+UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
+
+SRC_URI[archive.md5sum] = "cdd0d0c8664056deb78aa40c88ec24d1"
+SRC_URI[archive.sha256sum] = "9981a20babf8da7744b7fbe175b9e36078bf08f3bf65fe5aedeb82cfe27ac11f"
+
+# allow cross build mixed with build of native tools
+do_write_config_append() {
+ cat >${WORKDIR}/meson.native <<EOF
+[binaries]
+pkgconfig = 'pkg-config-native'
+EOF
+}
+EXTRA_OEMESON = "--native-file ${WORKDIR}/meson.native"
+
+PACKAGECONFIG ??= " \
+ cups nm \
+ alsa gudev \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)} \
+"
+PACKAGECONFIG[alsa] = "-Dalsa=true,-Dalsa=false,alsa-lib"
+PACKAGECONFIG[cups] = "-Dcups=true,-Dcups=false,cups"
+PACKAGECONFIG[gudev] = "-Dgudev=true,-Dgudev=false,libgudev"
+PACKAGECONFIG[nm] = "-Dnetwork_manager=true,-Dnetwork_manager=false,networkmanager"
+PACKAGECONFIG[wayland] = "-Dwayland=true,-Dwayland=false,wayland"
+
+FILES_${PN} += " \
+ ${systemd_user_unitdir} \
+ ${libdir}/gnome-settings-daemon-3.0/libgsd.so \
+"
+
+RDEPEND_${PN} += "gdbus"