meta-openembedded: subtree update:55de2d06ad..53d431639a
Adrian Bunk (1):
ltrace: Remove RDEPENDS on elfutils
Andreas Müller (22):
gedit: upgrade 2.30.4 -> 3.34.0
gtksourceview2: remove
evolution-data-server: give up fine grained -dev/-dbg packages
evolution-data-server: upgrade 3.26.6 -> 3.34.1 and rework
gnome-font-viewer: initial add 3.34.0
evince: upgrade 3.28.2 -> 3.34.1
file-roller: inital add 3.32.2
gexiv2: initial add 0.12.0
gnome-autoar: inital add 0.2.3
tracker: initial add 2.3.1
nautilus: upgrade 3.18.5 -> 3.34.1
geocode-glib: initial add 3.26.1
libgweather: initial add 3.34.0
libwacom: initial add 0.33
gnome-settings-daemon: initial add 3.34.1
fluidsynth: upgrade 2.0.7 -> 2.0.9
gnome-terminal: re-add 3.34.2
gnome-terminal: Fix build for musl
gmime: cleanup recipe
gmime: move to meta-oe/recipes-gnome
gmime: upgrade 3.2.4 -> 3.2.5
evolution-data-server: add upstream-version-is-even & gsettings to inherit
Bartosz Golaszewski (1):
libgpiod: put gpio utils into an actual separate package
Gaylord Charles (1):
nginx: fix install paths
Khem Raj (11):
evince: Fix build with clang
poppler: Extend the c/c++ flags fix to cover clang
pidgin-sipe: Fix another case of struct incompatiblility due to 64bit time_t
gperftools: Convert static and libunwind support to packageconfig
libmad: Define O2 for all arches as default optimization
rsyslog: Dont force enable atomic builtins on mips
libtorrent: Drop 64bit atomics patch for mips/ppc
libtorrent: Disable instrumentation on ppc/mips
libkcapi: Move static inline functions where used
grpc: Link with libatomic on clang/x86
upm: Link with libatomic on clang/x86
Leon Anavi (1):
surf: Add a simple web browser
Martin Balik (1):
squid: upgrade 4.6 -> 4.9
Nicola Lunghi (2):
python-jsonschema: multiple fixes
python-jsonschema: add PACKAGECONFIG nongpl option
Oleksandr Kravchuk (1):
flatbuffers: update to 1.11.0
Peter Kjellerstedt (1):
libldb: Do not require the "pam" distro feature to be enabled
nick83ola (2):
python3-apply-defaults: add recipe
python3-jsonrpcserver: add recipe
Change-Id: I231fc015cba86b7c14915ffc3f6f123c9296fd68
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-gnome/recipes-gnome/tracker/tracker_2.3.1.bb b/meta-openembedded/meta-gnome/recipes-gnome/tracker/tracker_2.3.1.bb
new file mode 100644
index 0000000..ad65630
--- /dev/null
+++ b/meta-openembedded/meta-gnome/recipes-gnome/tracker/tracker_2.3.1.bb
@@ -0,0 +1,50 @@
+SUMMARY = "Tracker is a file search engine"
+LICENSE = "GPLv2 & LGPLv2.1"
+LIC_FILES_CHKSUM = " \
+ file://COPYING.GPL;md5=ee31012bf90e7b8c108c69f197f3e3a4 \
+ file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \
+"
+
+DEPENDS = " \
+ libxml2-native \
+ dbus-native \
+ glib-2.0 \
+ sqlite3 \
+ libarchive \
+ dbus \
+ icu \
+ json-glib \
+ libsoup-2.4 \
+ libstemmer \
+"
+
+GNOMEBASEBUILDCLASS = "meson"
+
+inherit gnomebase gobject-introspection vala gtk-doc manpages bash-completion distro_features_check
+
+SRC_URI[archive.md5sum] = "5e75b611b190c4cebf53e3de15266429"
+SRC_URI[archive.sha256sum] = "b6748726e465ad2f4d991560634b1fd0df8841f3d981b3b837c4162abedf08a1"
+
+# gobject-introspection is mandatory and cannot be configured
+REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
+UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
+
+PACKAGECONFIG ??= "fts"
+PACKAGECONFIG[networkmanager] = "-Dnetwork_manager=enabled,-Dnetwork_manager=disabled,networkmanger"
+# full text search requires sqlite3 build with PACKAGECONFIG[fts5] set
+PACKAGECONFIG[fts] = "-Dfts=true,-Dfts=false"
+
+# set required cross property sqlite3_has_fts5
+do_write_config[vardeps] += "PACKAGECONFIG"
+do_write_config_append() {
+ echo "[properties]" > ${WORKDIR}/meson-tracker.cross
+ echo "sqlite3_has_fts5 = '${@bb.utils.contains('PACKAGECONFIG', 'fts', 'true', 'false', d)}'" >> ${WORKDIR}/meson-tracker.cross
+}
+
+EXTRA_OEMESON = "--cross-file ${WORKDIR}/meson-tracker.cross"
+
+FILES_${PN} += " \
+ ${datadir}/dbus-1 \
+ ${libdir}/tracker-2.0 \
+ ${systemd_user_unitdir} \
+"