Mount a specified PNOR UBIFS volume
Create a template systemd unit file to mount a specified PNOR UBIFS
volume (systemd does not support template mount files).
Create it with an arbitrary size of 1MB, it can be dynamically resized
at runtime.
Example usage:
systemctl start obmc-flash-bios-ubimount@N where N is the desired
partition number, ex: 1.
This will create a volume named pnor-rwN (ex: pnor-rw1) under the /media
directory.
Change-Id: I6c4d8662dfb50e83d02bfb946ce11b74726fe3bd
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios.bb b/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios.bb
index 9fdd7e3..7398cbd 100644
--- a/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios.bb
+++ b/meta-phosphor/common/recipes-phosphor/flash/obmc-flash-bios.bb
@@ -13,3 +13,4 @@
DBUS_SERVICE_${PN} += "org.openbmc.control.Flash.service"
SYSTEMD_SERVICE_${PN} += "obmc-flash-init.service"
SYSTEMD_SERVICE_${PN} += "obmc-flash-bios-ubiattach.service"
+SYSTEMD_SERVICE_${PN} += "obmc-flash-bios-ubimount@.service"