e3c246d4i: enable x86-power-control
The config has a slight hack regarding the SioPowerGood/PowerOk signals
(as explained in a comment in the file). The O_PWROK GPIO line perhaps
"should" be the SioPowerGood signal, but we also don't have
SioOnControl, so power-control disables its SIO support anyway, and
using O_PWROK as PowerOk seems to work alright.
Signed-off-by: Zev Weiss <zev@bewilderbeest.net>
Change-Id: Ie3ef974e7edc172c82f63cb0129d90d098b15906
diff --git a/meta-asrock/meta-e3c246d4i/recipes-x86/chassis/x86-power-control_%.bbappend b/meta-asrock/meta-e3c246d4i/recipes-x86/chassis/x86-power-control_%.bbappend
new file mode 100644
index 0000000..f54fe06
--- /dev/null
+++ b/meta-asrock/meta-e3c246d4i/recipes-x86/chassis/x86-power-control_%.bbappend
@@ -0,0 +1,10 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += " \
+ file://power-config-host0.json \
+ "
+
+do_install:append() {
+ install -d ${D}/${datadir}/${PN}
+ install -m 0644 ${WORKDIR}/power-config-host0.json ${D}/${datadir}/${PN}
+}