meta-on5263m5: Add inspur-uuid
The phsophor-led-sysfs needs only one pin
to control the led(linux led subsystem).
But inspur's motherbaord needs 2 pins
to manager the identify-led(only identify-led)
gpio_control 1-0-1 keep 0>50ms toggle the led
gpio_read get the led status(0 means on 1 means off)
Testd: Tested on the on5263m5 board
(From meta-inspur rev: c8f86c0b5d40b1fa6e7ecba096a148187859e089)
Change-Id: Ia3677a8e37b8888b8c679090b58bc2740763095e
Signed-off-by: John Wang <wangzqbj@inspur.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-inspur/meta-common/recipes-inspur/inspur-uuid/inspur-uuid_git.bb b/meta-inspur/meta-common/recipes-inspur/inspur-uuid/inspur-uuid_git.bb
new file mode 100644
index 0000000..2174da9
--- /dev/null
+++ b/meta-inspur/meta-common/recipes-inspur/inspur-uuid/inspur-uuid_git.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Inspur Identify LED Controller daemon"
+DESCRIPTION = "Daemon to trigger actions on a inspur identify LED"
+
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+inherit autotools pkgconfig
+inherit systemd
+
+DEPENDS += "autoconf-archive-native"
+DEPENDS += "sdbusplus"
+DEPENDS += "sdeventplus"
+DEPENDS += "phosphor-dbus-interfaces"
+DEPENDS += "phosphor-logging"
+DEPENDS += "gpioplus"
+
+
+SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.inspur.identify_led.controller.service"
+
+SRC_URI = "git://github.com/inspur-bmc/inspur-uuid.git"
+
+PV = "1.0+git${SRCPV}"
+SRCREV = "703633f2e81ba4d59eef74910c019e91d2bac63c"
+
+S = "${WORKDIR}/git"