aspeed: provide suitable kernel build defaults
oe-core has these defaults:
KERNEL_IMAGETYPE: "zimage"
KERNEL_CLASSES: "kernel-uimage"
INITRAMFS_IMAGE: ""
INITRAMFS_FSTYPES: "cpio.gz"
Override those defaults with Aspeed specific defaults that are more
appropriate to the current state of typical usage (FIT) of Aspeed chips:
KERNEL_IMAGETYPE: "fitImage"
KERNEL_CLASSES: "kernel-fitimage"
INITRAMFS_IMAGE: "aspeed-image-initramfs"
INITRAMFS_FSTYPES: "cpio.xz"
By default use aspeed-image-initramfs in the FIT image.
aspeed-image-initramfs is just an alias to core-image-minimal. The
alias is required because vanilla core-image-minimal is not an initramfs
image recipe...in oe, in general, the usage of the image recipe
(initramfs or not) is baked into the recipe itself with a line like:
IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
The same behavior *could* be obtained with a bbappend but that then
prevents users from using the original image recipe as a real root
filesystem image in their setups.
Perhaps at a later time a replacement image with an Aspeed hardware
evaluation kit theme would be a more suitable default.
(From meta-aspeed rev: 7639df3650f6d91c9b533e0287142fdcfbc0b2ea)
Change-Id: I51def69bcfd786f4c8aad2ae68376da335aad039
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-aspeed/recipes-aspeed/images/aspeed-image-initramfs.bb b/meta-aspeed/recipes-aspeed/images/aspeed-image-initramfs.bb
new file mode 100644
index 0000000..9f45021
--- /dev/null
+++ b/meta-aspeed/recipes-aspeed/images/aspeed-image-initramfs.bb
@@ -0,0 +1,3 @@
+IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+
+require recipes-core/images/core-image-minimal.bb