meta-openembedded: refresh master: 0435c9e193..4a9deabbc8
Update meta-openembedded to master HEAD.
Alistair Francis (7):
python3-pyaudio: Initial commit
python3-pyfann2: Initial commit
python3-pocketsphinx: Initial commit
python3-xxhash: Initial commit
mycroft: Initial commit
libfann: Initial commit
python-cryptography: Bump from 2.4.1 to 2.6.1
Andreas Müller (10):
xfce4-screenshooter: upgrade 1.9.4 -> 1.9.5
networkmanager: Fix upstream regex for 1.16
networkmanager: fix build with musl
gvfs: fix configure options and DDEPENDS
rrdtool: fix build by disabling docs
libpeas: rework gobject-introspection handling
gvfs: Fix missing executable permission flags for files in libexec
gnome-desktop3: remove gconf from DEPENDS
gnome-desktop3: rework gobject-introspection handling
gnome-desktop3: Disable libseccomp for all archs
Brad Bishop (1):
libvncserver: enable split client/server packages
Fabio Berton (1):
python*-requests: Update 2.20.1 -> 2.21.0
Gianfranco Costamagna (2):
cpprest: fix build failure on 32bit systems, with upstream merged patch
libmodbus: start to prefer version 3.1.4 as default
Hongxu Jia (1):
dracut: fix udevdir not found
Khem Raj (5):
ncmpc: Rename artist_screen to library_screen
networkmanager: Fix build with clang
alsa-oss: Upgrade to 1.1.8
redis: Fix ocasional parallel build failure
lcdproc: Fix parallel build
Nikolay Nizov (2):
android-tools-conf: fix typo
android-tools-conf: Make sure /dev/pts/0 exists
Oleksandr Kravchuk (2):
fping: update to 4.2
nuttcp: update to 7.3.3
Peter Kjellerstedt (1):
doxygen: Make it build with ninja 1.9.0
Qi.Chen@windriver.com (2):
openldap: add missing CVE tag to patch
ipsec-tools: add missing CVE tags to patches
Randy MacLeod (2):
imagemagic: upgrade to 7.0.8-35
wolfssl: update to 3.15.8 and use github SRC_URI
Slater, Joseph (1):
tcpreplay: update to version 4.3.2
Vincent Prince (4):
Rsyslog: Add mmjsonparse to PACKAGECONFIG
zeromq: bump version 4.2.5 => 4.3.1
cppzmq: bump version 4.2.3 => 4.3.0
czmq: bump version 4.1.1 => 4.2.0
Yi Zhao (3):
python-engineio: add recipe
python-socketio: add recipe
python-flask-socketio
Zang Ruochen (4):
augeas: upgrade 1.10.1 -> 1.11.0
libedit: upgrade 20181209-3.1 -> 20190324-3.1
mcelog: upgrade 161 -> 162
lockfile-progs: upgrade 0.1.17 -> 0.1.18
leimaohui (1):
Fix build error for armeb.
Change-Id: Ie79748c484bcf4fd28b3bde84e2194044e1c08a8
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-multimedia/alsa/alsa-oss_1.1.8.bb b/meta-openembedded/meta-oe/recipes-multimedia/alsa/alsa-oss_1.1.8.bb
new file mode 100644
index 0000000..46ab503
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-multimedia/alsa/alsa-oss_1.1.8.bb
@@ -0,0 +1,46 @@
+# FIXME: the LIC_FILES_CHKSUM values have been updated by 'devtool upgrade'.
+# The following is the difference between the old and the new license text.
+# Please update the LICENSE value if needed, and summarize the changes in
+# the commit message via 'License-Update:' tag.
+# (example: 'License-Update: copyright years updated.')
+#
+# The changes:
+#
+# --- COPYING
+# +++ COPYING
+# @@ -2,7 +2,8 @@
+# Version 2, June 1991
+#
+# Copyright (C) 1989, 1991 Free Software Foundation, Inc.
+# - 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+# + 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
+# +
+# Everyone is permitted to copy and distribute verbatim copies
+# of this license document, but changing it is not allowed.
+#
+#
+#
+
+SUMMARY = "Alsa OSS Compatibility Package"
+SECTION = "libs/multimedia"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=ed055b4eff93da784176a01582e6ec1a"
+DEPENDS = "alsa-lib"
+
+SRC_URI = "ftp://ftp.alsa-project.org/pub/oss-lib/alsa-oss-${PV}.tar.bz2 \
+ file://libio.patch \
+"
+SRC_URI[md5sum] = "9ec4bb783fdce19032aace086d65d874"
+SRC_URI[sha256sum] = "64adcef5927e848d2e024e64c4bf85b6f395964d9974ec61905ae4cb8d35d68e"
+
+inherit autotools
+
+LEAD_SONAME = "libaoss.so.0"
+
+do_configure_prepend () {
+ touch NEWS README AUTHORS ChangeLog
+ sed -i "s/libaoss.so/${LEAD_SONAME}/" ${S}/alsa/aoss.in
+}
+
+# http://errors.yoctoproject.org/Errors/Details/186961/
+EXCLUDE_FROM_WORLD_libc-musl = "1"