meta-openembedded: subtree update:41fe46157c..e6d76b05a7
Adrian Bunk (1):
networkmanager: Correct the upstream version check
Adrian Ratiu (1):
renderdoc: add new recipe
Changqing Li (1):
kea: upgrade 1.5.0 -> 1.7.0
Denys Dmytriyenko (1):
rwmem: add recipe
Hongxu Jia (1):
lvm2: fix run lvcreate hung while PACKAGECONFIG udev
Jackie Huang (6):
python-versiontools: add recipes for python2 and python3
python-pymysql: add recipes for python2 and python3
python-statistics: add new recipe
python-pyperf: add recipes for python2 and python3
python-pika: add recipes for python2 and python3
python-pycurl: add recipes for python2 and python3
Khem Raj (6):
openipmi: Mark libOpenIPMI.so.0 as private lib in openipmi-perl
ttf-gentium: Use OFL-1.0 version of OFL license
ttf-hunkyfonts: Use LGPL-2.1 which is correct version from LICENSE file
python-configparser: Mark license as MIT
fontforge: Upgrade to 20190801 release
opensaf: Fix duplicate copies of shared libs in package
Martin Jansa (2):
spice: ignore all warnings not just address-of-packed-member
Revert "spice: Drop broken native"
Otavio Salvador (5):
networkmanager: Fix ADSL plugin packaging
networkmanager: Add a `resolvconf` PACKAGECONFIG
networkmanager: Add sysvinit support
libqmi: Upgrade 1.22.2 -> 1.24.0
modemmanager: Upgrade 1.10.0 -> 1.10.2
Qi.Chen@windriver.com (1):
protobuf-c: fix race condition
Robert Yang (2):
corosync: Fix PACKAGECONFIG flag for rdma
net-snmp: Fix PACKAGECONFIG for perl
Zang Ruochen (1):
python-urllib3: upgrade 1.25.5 -> 1.25.6
Change-Id: I20029cc79a225f6ab8f1b133ebc16129b7b32082
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.10.2.bb b/meta-openembedded/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.10.2.bb
new file mode 100644
index 0000000..5fe7fb8
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.10.2.bb
@@ -0,0 +1,57 @@
+SUMMARY = "ModemManager is a daemon controlling broadband devices/connections"
+DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections"
+HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/"
+LICENSE = "GPL-2.0 & LGPL-2.1"
+LIC_FILES_CHKSUM = " \
+ file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
+"
+
+inherit gnomebase gettext systemd vala gobject-introspection bash-completion
+
+DEPENDS = "glib-2.0 libgudev intltool-native libxslt-native"
+
+SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz \
+ "
+
+SRC_URI[md5sum] = "dad80b3b4f27c1d6eae7e019542338be"
+SRC_URI[sha256sum] = "bbcf6da35da3d72f688675bde91dfed6485845c3fedd1805ae914b71d1b783f2"
+
+S = "${WORKDIR}/ModemManager-${PV}"
+
+PACKAGECONFIG ??= "mbim qmi \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'systemd polkit', d)} \
+"
+
+PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,"
+PACKAGECONFIG[polkit] = "--with-polkit=yes,--with-polkit=no,polkit"
+# Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol.
+PACKAGECONFIG[mbim] = "--with-mbim,--without-mbim,libmbim"
+# Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol.
+PACKAGECONFIG[qmi] = "--with-qmi,--without-qmi,libqmi"
+
+EXTRA_OECONF = " \
+ --with-udev-base-dir=${nonarch_base_libdir}/udev \
+"
+EXTRA_OECONF_append_toolchain-clang = " --enable-more-warnings=no"
+
+FILES_${PN} += " \
+ ${datadir}/icons \
+ ${datadir}/polkit-1 \
+ ${datadir}/dbus-1 \
+ ${datadir}/ModemManager \
+ ${libdir}/ModemManager \
+ ${systemd_unitdir}/system \
+"
+
+FILES_${PN}-dev += " \
+ ${libdir}/ModemManager/*.la \
+"
+
+FILES_${PN}-staticdev += " \
+ ${libdir}/ModemManager/*.a \
+"
+
+FILES_${PN}-dbg += "${libdir}/ModemManager/.debug"
+
+SYSTEMD_SERVICE_${PN} = "ModemManager.service"