tyan, s7106: Initial commit for TYAN S7106

The TYAN S7106 is a server mainboard with an Aspeed AST2500 BMC.

Signed-off-by: Oskar Senft <osk@google.com>
Change-Id: I75e4938bbc7d25bd8e949a4bae5761205aa0ff22
diff --git a/meta-tyan/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend b/meta-tyan/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend
new file mode 100644
index 0000000..c0fe1dd
--- /dev/null
+++ b/meta-tyan/meta-common/recipes-x86/chassis/x86-power-control_%.bbappend
@@ -0,0 +1,11 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+SRC_URI:append = " \
+    file://power-config-host0.json \
+"
+
+RDEPENDS:${PN}:append = " bash"
+
+do_install:append() {
+    install -d ${D}${datadir}/${PN}
+    install -m 0644 ${WORKDIR}/power-config-host0.json ${D}${datadir}/${PN}
+}