meta-ampere: Support Ampere password policy
Implement Ampere password policy as followings:
- Password must between 9-20 characters, 1 lower case, 1 upper case,
one digit and 1 special character.
- No more than 3 consecutive identical characters.
Signed-off-by: Hieu Huynh <hieuh@os.amperecomputing.com>
Change-Id: I20134f51e06ef0aabeddfc4d1560acfa7483deab
diff --git a/meta-ampere/meta-common/recipes-extended/pam/libpam_%.bbappend b/meta-ampere/meta-common/recipes-extended/pam/libpam_%.bbappend
new file mode 100644
index 0000000..4ede033
--- /dev/null
+++ b/meta-ampere/meta-common/recipes-extended/pam/libpam_%.bbappend
@@ -0,0 +1,4 @@
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += " file://pam.d/common-password \
+ "