poky: subtree update:a8544811d7..b5763b2f48
Alexander Kanavin (29):
rpm: upgrade to 4.15.1
libmodulemd: move from 1.x to 2.x version
libdnf: upgrade 0.28.1 -> 0.47.0
dnf: upgrade 4.2.2 -> 4.2.21
dnf: add a patch for base-files installation failures
logrotate: update to 3.16.0
rt-tests: further exclusion of development versions
kmscube: update to latest commit
xcb-proto: update to 1.14
libxcb: update to 1.14
ghostscript: do not hardcode version in SRC_URI
ghostscript: update 9.50 -> 9.52
webkitgtk: update to 2.28.2
python3-gitdb: update to 4.0.4
libevdev: update to 1.9.0
python3-dbusmock: add recipe from meta-oe
mc: update to 4.8.24
coreutils: update to 8.32
glib-2.0: update 2.62.4 -> 2.64.2
glib-networking: update to 2.64.2
gptfdisk: update to 1.0.5
clutter-1.0: update to 1.26.4
diffoscope: update to 143
wpe: update to 1.6.0
vte: update to 0.60.2
libnotify: update to 0.7.9
connman: update to 1.38
xkeyboard-config: update to 2.29
gcr: update to 3.36.0
Andreas M?ller (1):
libsecret: upgrade 0.20.1 -> 0.20.3 / port to meson
Anibal Limon (2):
ptest-runner: Bump to 2.4.0
oeqa/runtime: Use libdir to run ptest-runner
Bartłomiej Burdukiewicz (2):
libva: add PACKAGECONFIG and additonal rules for glx.
libva: removed opengl from REQUIRED_DISTRO_FEATURES.
Benjamin Fair (1):
util-linux: fix build error in kill
Bruce Ashfield (4):
linux-yocto/5.4: update to v5.4.28
linux-yocto/5.4: update to v5.4.32
linux-yocto-dev: bump to v5.7-rc
linux-yocto/5.4: update to v5.4.34
Frazer Clews (2):
bitbake: lib/toaster: fixup codebase so pydocstyle can parse
bitbake: lib/bs4/testing.py: fix bs4 testing
Jan Luebbe (1):
openssl: upgrade 1.1.1f -> 1.1.1g
Joshua Watt (1):
jquery: Upgrade 3.4.1 -> 3.5.0
Khem Raj (2):
dpkg: Add riscv32 CPU support
musl: Remove spurious unused patch
Mingli Yu (1):
iputils: Initialize libgcrypt
Peter Kjellerstedt (1):
libdnf: Use single-quotes around string literals used in SQL statements
Pierre-Jean Texier (3):
timezone: upgrade 2019c -> 2020a
curl: upgrade 7.69.1 -> 7.70.0
curl: support mqtt in PACKAGECONFIG
Richard Purdie (6):
sanity: Require gcc 6 or later
gcc-target: Ensure buildtools-extended-tarball doesn't use arch=native
abi_version/staging: Bump versions to force rebuild after sstate corruption
bitbake: bitdoc: Remove it
utils: Drop FILESPATHPKG usage
utils: Drop is_machine_specific()/machine_paths()
Robert P. J. Day (5):
ref-manual: fix excessive command indentation
ref-manual: IMAGE_TYPES, add tar.zst, delete elf
ref-manual: typo "SSTATE_MIRROR" -> "SSTATE_MIRRORS"
ref-manual: Remove long-dead PACKAGE_GROUP variable
bitbake: docs: delete reference to obsolete recipe-depends.dot
Sakib Sajal (1):
sqlite: backport CVE fixes
Tim Orling (2):
atk: upgrade 2.34.1 -> 2.36.0
at-spi2-core: upgrade 2.34.0 -> 2.36.0
Vyacheslav Yurkov (1):
os-release: sanitize required fields
Wang Mingyu (1):
icu: CVE-2020-10531
Change-Id: Iae5641be5ca6424275d2e0d63ba3a7a5ba90cde2
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/poky/meta/recipes-devtools/fdisk/gptfdisk_1.0.5.bb b/poky/meta/recipes-devtools/fdisk/gptfdisk_1.0.5.bb
new file mode 100644
index 0000000..c7850f0
--- /dev/null
+++ b/poky/meta/recipes-devtools/fdisk/gptfdisk_1.0.5.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Utility for modifying GPT disk partitioning"
+DESCRIPTION = "GPT fdisk is a disk partitioning tool loosely modeled on Linux fdisk, but used for modifying GUID Partition Table (GPT) disks. The related FixParts utility fixes some common problems on Master Boot Record (MBR) disks."
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
+
+DEPENDS = "util-linux"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${PV}/${BP}.tar.gz \
+ file://0001-gptcurses-correctly-include-curses.h.patch \
+ "
+SRC_URI[md5sum] = "58dac67c85e46ca87b587231549aefe6"
+SRC_URI[sha256sum] = "0e7d3987cd0488ecaf4b48761bc97f40b1dc089e5ff53c4b37abe30bc67dcb2f"
+
+UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/gptfdisk/files/gptfdisk/"
+UPSTREAM_CHECK_REGEX = "/gptfdisk/(?P<pver>(\d+[\.\-_]*)+)/"
+
+EXTRA_OEMAKE = "'CC=${CC}' 'CXX=${CXX}' gdisk fixparts ${PACKAGECONFIG_CONFARGS}"
+
+PACKAGECONFIG ??= "ncurses popt"
+PACKAGECONFIG[ncurses] = "cgdisk,,ncurses"
+PACKAGECONFIG[popt] = "sgdisk,,popt"
+
+do_install() {
+ install -d ${D}${sbindir}
+ for f in cgdisk sgdisk; do
+ if [ -x $f ]; then
+ install -m 0755 $f ${D}${sbindir}
+ fi
+ done
+ install -m 0755 gdisk ${D}${sbindir}
+ install -m 0755 fixparts ${D}${sbindir}
+}
+
+BBCLASSEXTEND = "native nativesdk"