meta-raspberrypi: subtree update:39cf54c3cb..a6f1233d52
Jon Magnuson (1):
packagegroup-rpi-test: resolve `wireless-regdb` conflict
Khem Raj (1):
linux-raspberrypi_5.4.bb: Upgrade to 5.4.47
Leon Anavi (7):
lirc_%.bbappend: Fix for gpio-ir
lirc: Move to dynamic-layers
rpi-config: Add ENABLE_IR variable for infrared
rpi-base.inc: Include modules if IR is enabled
lirc_%.bbappend: Use lircd.service as in Raspbian
docs/extra-build-config.md: Infrared
lirc: Rename bbappend to match only version 0.10.1
M. ter Woord (1):
Update layer-contents.md to include pi4
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I6f20c20dec1dd2fdab9e4e52dea1cdd54be4fffc
diff --git a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
index 5315676..d964de5 100644
--- a/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -25,6 +25,8 @@
VC4GRAPHICS="${@bb.utils.contains("MACHINE_FEATURES", "vc4graphics", "1", "0", d)}"
VC4DTBO ?= "vc4-kms-v3d"
+GPIO_IR ?= "18"
+GPIO_IR_TX ?= "17"
inherit deploy nopackages
@@ -161,6 +163,13 @@
echo "enable_uart=1" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
fi
+ # Infrared support
+ if [ "${ENABLE_IR}" = "1" ]; then
+ echo "# Enable infrared" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=gpio-ir,gpio_pin=${GPIO_IR}" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "dtoverlay=gpio-ir-tx,gpio_pin=${GPIO_IR_TX}" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ fi
+
# VC4 Graphics support
if [ "${VC4GRAPHICS}" = "1" ]; then
echo "# Enable VC4 Graphics" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt