gpioplus: Convert to meson

We intend to remove autotools from the gpioplus build eventually. This
is the final step needed to use meson for the package.

(From meta-phosphor rev: c86057c5636542ad7fa86bbd2a31b9090a8c2a30)

Change-Id: Ided281441177e3f4f136d5a84ad3b139adb0000e
Signed-off-by: William A. Kennington III <wak@google.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb b/meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb
index d60310e..5a67b20 100644
--- a/meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb
+++ b/meta-phosphor/recipes-extended/gpioplus/gpioplus_git.bb
@@ -6,14 +6,13 @@
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
 
-inherit autotools pkgconfig
+inherit meson pkgconfig
 
-DEPENDS += " \
-        autoconf-archive-native \
+EXTRA_OEMESON = " \
+        -Dexamples=false \
+        -Dtests=disabled \
         "
 
-EXTRA_OECONF = "--disable-examples --disable-tests"
-
 SRC_URI += "git://github.com/openbmc/gpioplus"
 SRCREV = "48e6288da8486a25fd52e944fb0f7148fc1c02db"