meta-phosphor: use systemd_system_unitdir
This variable was added to bitbake.conf so lets use it. Using it is
best pratice and enables things like alternative base_libdir paths.
Change-Id: I181d12e02ca7918614dacec68bd8e033932eb0ab
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb b/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
index 5fcfeea..596c182 100644
--- a/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
+++ b/meta-phosphor/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb
@@ -49,8 +49,8 @@
sed -i -e 's/^gid nslcd/# gid nslcd/;' ${D}${sysconfdir}/nslcd.conf
sed -i -e 's/^base dc=example,dc=com/base ${LDAP_DN}/;' ${D}${sysconfdir}/nslcd.conf
- install -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/nslcd.service ${D}${systemd_unitdir}/system
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/nslcd.service ${D}${systemd_system_unitdir}
}
inherit update-rc.d systemd