subtree updates

meta-raspberrypi: cfbb192e5c..83f5577d8d:
  AJ Bagwell (1):
        linux-raspberrypi: add UBOOT_ENTRYPOINT to match LOADADDR

poky: ed98f1a1ae..30b38d9cb9:
  Alexander Kanavin (1):
        connman-conf: ignore eth0 in qemu in a way that is not sysvinit-specific

  Chen Qi (1):
        spirv-tools: fix to use sdk-1.3.204 branch

  Kevin Hao (1):
        kernel.bbclass: Fix the do_strip() malfunction

  Khem Raj (2):
        libarchive: Upgrade to 3.6.1
        musl: Move to 1.2.3 release tag

  Martin Jansa (1):
        license_image.bbclass: close package.manifest file

  Ralph Siemsen (2):
        xz: fix CVE-2022-1271
        gzip: upgrade 1.11 -> 1.12

  Richard Purdie (2):
        uninative: Upgrade to 3.6 with gcc 12 support
        package_ipk/deb: Fix specific version handling

  Ross Burton (1):
        python3-cryptography: backport fix for leaky test

meta-openembedded: b9e440ead8..1888971b1f:
  Andreas Müller (5):
        octave: add PACKAGECONFIG for (Qt-)gui - disabled by default
        xfce4-eyes-plugin: upgrade 4.5.1 -> 4.6.0
        gnome-online-accounts: upgrade 3.43.1 -> 3.44.0
        mutter: upgrade 41.2 -> 42.0
        gnome-shell: upgrade 41.2 -> 42.0

  Clément Péron (1):
        grpc: remove unused patches

  Kai Kang (2):
        wxwidgets: fix wx-config multilib issue
        python3-wxgtk4: pass '--baselib' to WX_CONFIG

  Khem Raj (6):
        Revert "python3-cppy: upgrade 1.2.0 -> 1.2.1"
        libotr: Include missing sys/socket.h header
        libcereal: Link in libatomic on rv32 for ptests
        gnuplot: Disable libcerf and fix typo
        libcereal: Disable on ppc/ppc64
        evolution-data-server: Disable g-i on musl

  Markus Volk (1):
        gparted: update to v1.4.0

  Naveen Saini (1):
        ndctl: fix build failure with EXEWRAPPER_ENABLED False

  Oleksandr Kravchuk (27):
        python3-beautifulsoup: update to 4.11.1
        python3-bidict: update to 0.22.0
        python3-can: update t 4.0.0
        python3-elementpath: update to 2.5.0
        python3-flask-login: update to 0.6.0
        python3-flask: update to 2.1.1
        python3-gcovr: update to 5.1
        python3-google-api-core: update to 2.7.1
        python3-google-auth: update to 2.6.3
        python3-grpcio-tools: update to 1.45.0
        python3-ipython: update to 8.2.0
        python3-jmespath: update to 1.0.0
        python3-mypy: update to 0.942
        python3-pint: update to 0.19.1
        python3-portalocker: update to 2.4.0
        python3-pulsectl: update to 22.3.2
        python3-pycurl: update to 7.45.1
        python3-pymogo: update to 4.1.0
        python3-pyscaffold: update to 4.2.1
        python3-pytest-helpers-namespace: update to 2021.12.29
        python3-pywbem: update to 1.4.1
        python3-regex: update to 2022.3.15
        python3-sympy: update to 1.10.1
        python3-tqdm: update to 4.64.1
        python3-twitter: update to 4.8.0
        python3-xmlschema: update to 1.10.0
        python3-zeroconf: update to 0.38.4

  Robert Yang (1):
        python3-wxgtk4: Require DISTRO_FEATURES as gtk3

  Sakib Sajal (1):
        drbd-utils: update 9.13.1 -> 9.20.2

  Scott Murray (1):
        wxwidgets: Fix building without x11

  Stefan Herbrechtsmeier (2):
        grpc: add cmake support for target
        grpc: remove useless link with libatomic append

  Stefan Schmidt (4):
        ot-br-posix: add recipe for an OpenThread Border Router
        ot-daemon: add recipe for OpenThread daemon
        wpantund: add new recipe
        MAINTAINERS: add entry for OpenThread

  Willy Tu (1):
        googletests: Update SRC_URI to 9e71237 to move closer to lastest version

  Yi Zhao (1):
        libyang: do not inherit binconfig-disabled

  wangmy (9):
        haveged: upgrade 1.9.17 -> 1.9.18
        hidapi: upgrade 0.10.1 -> 0.11.2
        hwdata: upgrade 0.357 -> 0.358
        broadcom-bt-firmware: upgrade 12.0.1.1105_p2 -> 12.0.1.1105_p3
        byacc: upgrade 20211224 -> 20220128
        ctags: upgrade 5.9.20211114.0 -> 5.9.20220410.0
        feh: upgrade 3.6.1 -> 3.8
        fio: upgrade 3.29 -> 3.30
        grpc: upgrade 1.45.1 -> 1.45.2

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Ia6d6cf07c9398a7885df6b31b27019da4d8f01d8
diff --git a/meta-openembedded/meta-oe/recipes-devtools/grpc/grpc_1.45.2.bb b/meta-openembedded/meta-oe/recipes-devtools/grpc/grpc_1.45.2.bb
new file mode 100644
index 0000000..48d0f58
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-devtools/grpc/grpc_1.45.2.bb
@@ -0,0 +1,67 @@
+DESCRIPTION = "A high performance, open source, general-purpose RPC framework. \
+Provides gRPC libraries for multiple languages written on top of shared C core library \
+(C++, Node.js, Python, Ruby, Objective-C, PHP, C#)"
+HOMEPAGE = "https://github.com/grpc/grpc"
+SECTION = "libs"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6e4cf218112648d22420a84281b68b88"
+
+DEPENDS = "c-ares protobuf protobuf-native protobuf-c protobuf-c-native openssl libnsl2 abseil-cpp re2"
+DEPENDS:append:class-target = " googletest grpc-native "
+DEPENDS:append:class-nativesdk = " grpc-native "
+
+PACKAGE_BEFORE_PN = "${PN}-compiler"
+
+RDEPENDS:${PN}-compiler = "${PN}"
+RDEPENDS:${PN}-dev:append:class-native = " ${PN}-compiler"
+# Configuration above allows to cross-compile gRPC applications
+# In order to compile applications on the target, use the dependency below
+# Both dependencies are mutually exclusive
+# RDEPENDS:${PN}-dev += "${PN}-compiler"
+
+S = "${WORKDIR}/git"
+SRCREV_grpc = "b39ffcc425ea990a537f98ec6fe6a1dcb90470d7"
+BRANCH = "v1.45.x"
+SRC_URI = "git://github.com/grpc/grpc.git;protocol=https;name=grpc;branch=${BRANCH} \
+           file://0001-Revert-Changed-GRPCPP_ABSEIL_SYNC-to-GPR_ABSEIL_SYNC.patch \
+           file://0001-cmake-add-separate-export-for-plugin-targets.patch \
+           "
+# Fixes build with older compilers 4.8 especially on ubuntu 14.04
+CXXFLAGS:append:class-native = " -Wl,--no-as-needed"
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE = " \
+    -DgRPC_CARES_PROVIDER=package \
+    -DgRPC_ZLIB_PROVIDER=package \
+    -DgRPC_SSL_PROVIDER=package \
+    -DgRPC_PROTOBUF_PROVIDER=package \
+    -DgRPC_ABSL_PROVIDER=package \
+    -DgRPC_RE2_PROVIDER=package \
+    -DgRPC_INSTALL=ON \
+    -DCMAKE_CROSSCOMPILING=ON \
+    -DgRPC_INSTALL_LIBDIR=${baselib} \
+    -DgRPC_INSTALL_CMAKEDIR=${baselib}/cmake/${BPN} \
+    "
+
+PACKAGECONFIG ??= "cpp shared"
+PACKAGECONFIG[cpp] = "-DgRPC_BUILD_GRPC_CPP_PLUGIN=ON,-DgRPC_BUILD_GRPC_CPP_PLUGIN=OFF"
+PACKAGECONFIG[csharp] = "-DgRPC_BUILD_GRPC_CSHARP_PLUGIN=ON,-DgRPC_BUILD_GRPC_CSHARP_PLUGIN=OFF"
+PACKAGECONFIG[node] = "-DgRPC_BUILD_GRPC_NODE_PLUGIN=ON,-DgRPC_BUILD_GRPC_NODE_PLUGIN=OFF"
+PACKAGECONFIG[objective-c] = "-DgRPC_BUILD_GRPC_OBJECTIVE_C_PLUGIN=ON,-DgRPC_BUILD_GRPC_OBJECTIVE_C_PLUGIN=OFF"
+PACKAGECONFIG[php] = "-DgRPC_BUILD_GRPC_PHP_PLUGIN=ON,-DgRPC_BUILD_GRPC_PHP_PLUGIN=OFF"
+PACKAGECONFIG[python] = "-DgRPC_BUILD_GRPC_PYTHON_PLUGIN=ON,-DgRPC_BUILD_GRPC_PYTHON_PLUGIN=OFF"
+PACKAGECONFIG[ruby] = "-DgRPC_BUILD_GRPC_RUBY_PLUGIN=ON,-DgRPC_BUILD_GRPC_RUBY_PLUGIN=OFF"
+PACKAGECONFIG[protobuf-lite] = "-DgRPC_USE_PROTO_LITE=ON,-DgRPC_USE_PROTO_LITE=OFF,protobuf-lite"
+PACKAGECONFIG[shared] = "-DBUILD_SHARED_LIBS=ON,-DBUILD_SHARED_LIBS=OFF,,"
+
+do_configure:prepend() {
+    sed -i -e "s#lib/pkgconfig/#${baselib}/pkgconfig/#g" ${S}/CMakeLists.txt
+}
+
+BBCLASSEXTEND = "native nativesdk"
+
+FILES:${PN}-compiler += " \
+    ${bindir} \
+    ${libdir}/libgrpc_plugin_support${SOLIBS} \
+    "