classes-systemd: refactor substitutions

The exising mechanism for doing substitutions worked but was
cumbersome for expressing more than a handful.  Rework the
interfaces such that expressing many substitutions at once
is simpler.

Change-Id: I9ffee7a623219a797797cc8f085e7a06eaf74b3c
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/classes/obmc-phosphor-dbus-service.bbclass b/meta-phosphor/classes/obmc-phosphor-dbus-service.bbclass
index c5d50d0..ebe87af 100644
--- a/meta-phosphor/classes/obmc-phosphor-dbus-service.bbclass
+++ b/meta-phosphor/classes/obmc-phosphor-dbus-service.bbclass
@@ -103,8 +103,8 @@
         set_append(
             d, 'SYSTEMD_SERVICE_%s' % pkg, '%s%s.service' % (
                 prefix, service))
-        set_append(d, 'SYSTEMD_SUBSTITUTIONS_%s%s.service' % (prefix, service),
-            'BUSNAME:%s' % service)
+        set_append(d, 'SYSTEMD_SUBSTITUTIONS',
+            'BUSNAME:%s:%s%s.service' % (service, prefix, service))
 
 
     def add_sd_user(d, prefix, service, pkg):