Disable bmcweb static hosting in IBM layer

openbmc/bmcweb#5 tracks an issue with bmcweb and static
hosting of web files on IBM systems. Until this bug is
resolved, disable bmcweb from hosting the files.

Currently in the IBM layer, bmcweb is only used for redfish
support and the static hosting is not needed for the basic
redfish support to work.

Testing: Verified bmcweb now starts fine and responds
to redfish requests.

(From meta-ibm rev: 8891e02efa759bb3173a0985f194c1e9a0bc255b)

Change-Id: I1f1ac2008afdb787de6b034a71b6ed6b2d51422b
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-ibm/recipes-phosphor/bmcweb/bmcweb.bbappend b/meta-ibm/recipes-phosphor/bmcweb/bmcweb.bbappend
index e3f627f..3de4e3c 100644
--- a/meta-ibm/recipes-phosphor/bmcweb/bmcweb.bbappend
+++ b/meta-ibm/recipes-phosphor/bmcweb/bmcweb.bbappend
@@ -4,7 +4,7 @@
 EXTRA_OECMAKE += "-DBMCWEB_INSECURE_DISABLE_SSL=ON"
 
 # Only need redfish support
-EXTRA_OECMAKE += "-DBMCWEB_ENABLE_KVM=OFF -DBMCWEB_ENABLE_DBUS_REST=OFF"
+EXTRA_OECMAKE += "-DBMCWEB_ENABLE_KVM=OFF -DBMCWEB_ENABLE_DBUS_REST=OFF -DBMCWEB_ENABLE_STATIC_HOSTING=OFF"
 
 # override service and socket file to use nginx
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"