meta-quanta: gbs: add xml for igps and patch/dts for u-boot
1.XML:
change the SPI speed to 19Mhz
2.U-boot:
dts/pinctrl: add GBS dts/pinctrl support
Nuvoton u-boot srcrev bump adb4ac1af3...6870e66f6b:
https://gerrit.openbmc-project.xyz/c/openbmc/meta-nuvoton/+/34756
3.modify u-boot environment partiions offset for GBS
(From meta-quanta rev: 705d71a8a0ee00f89f06c95601aa1375a440611a)
Signed-off-by: George Hung <george.hung@quantatw.com>
Change-Id: I47960d63b557f6de1c9d84b290094253f4ffba58
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-quanta/meta-gbs/recipes-bsp/images/npcm7xx-igps-native_%.bbappend b/meta-quanta/meta-gbs/recipes-bsp/images/npcm7xx-igps-native_%.bbappend
new file mode 100644
index 0000000..06bc31f
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-bsp/images/npcm7xx-igps-native_%.bbappend
@@ -0,0 +1,12 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI_append += "file://BootBlockAndHeader_GBS.xml"
+SRC_URI_append += "file://UbootHeader_GBS.xml"
+
+# Prepare the Bootblock XMLs.
+do_gbs_prepare_xmls() {
+ cp ${WORKDIR}/BootBlockAndHeader_GBS.xml ${S}/ImageGeneration/references/
+ cp ${WORKDIR}/UbootHeader_GBS.xml ${S}/ImageGeneration/references/
+}
+
+addtask do_gbs_prepare_xmls after do_patch before do_install