meta-quanta: gbs: add xml for igps and patch/dts for u-boot
1.XML:
change the SPI speed to 19Mhz
2.U-boot:
dts/pinctrl: add GBS dts/pinctrl support
Nuvoton u-boot srcrev bump adb4ac1af3...6870e66f6b:
https://gerrit.openbmc-project.xyz/c/openbmc/meta-nuvoton/+/34756
3.modify u-boot environment partiions offset for GBS
(From meta-quanta rev: 705d71a8a0ee00f89f06c95601aa1375a440611a)
Signed-off-by: George Hung <george.hung@quantatw.com>
Change-Id: I47960d63b557f6de1c9d84b290094253f4ffba58
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-quanta/meta-gbs/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend b/meta-quanta/meta-gbs/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend
new file mode 100644
index 0000000..8b66271
--- /dev/null
+++ b/meta-quanta/meta-gbs/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_%.bbappend
@@ -0,0 +1,6 @@
+FILESEXTRAPATHS_prepend_gbs := "${THISDIR}/${PN}:"
+SRC_URI_append_gbs = " file://fw_env.config"
+
+do_install_append_gbs() {
+ install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+}