ibm: fans: Replace rainier with p10bmc
The IBM rainier machine name is being replaced with the generic p10bmc.
Tested: Built rainier and verified the fan files were installed, ex:
obmc-phosphor-image/1.0-r0/rootfs/usr/share/phosphor-fan-presence/control/ibm,rainier-4u/zones.json
obmc-phosphor-image/1.0-r0/rootfs/usr/share/phosphor-fan-presence/control/ibm,rainier-2u/zones.json
obmc-phosphor-image/1.0-r0/rootfs/usr/share/phosphor-fan-presence/control/ibm,everest/zones.json
Change-Id: I10edb9e30716cffa3f510fe94822eadb08326912
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
index 8817592..2306ee5 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan-presence-config.bbappend
@@ -1,7 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
SRC_URI_witherspoon = "file://config.json"
-SRC_URI_rainier = "file://rainier-2u/config.json \
+SRC_URI_p10bmc = "file://rainier-2u/config.json \
file://rainier-4u/config.json \
file://rainier-1s4u/config.json \
file://everest/config.json \
@@ -11,7 +11,7 @@
install -d ${D}/${datadir}/phosphor-fan-presence/presence/
install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/presence/
}
-do_install_rainier() {
+do_install_p10bmc() {
# Install Rainier-2U/4U fan presence config files
install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/
install -d ${D}/${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/
@@ -28,8 +28,8 @@
FILES_${PN}_append_witherspoon = " ${datadir}/phosphor-fan-presence/presence/config.json"
FILES_${PN}_remove_witherspoon = "${presence_datadir}/config.yaml"
-FILES_${PN}_remove_rainier = "${presence_datadir}/config.yaml"
-FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/config.json"
-FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/config.json"
-FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/config.json"
-FILES_${PN}_append_rainier = " ${datadir}/phosphor-fan-presence/presence/ibm,everest/config.json"
+FILES_${PN}_remove_p10bmc = "${presence_datadir}/config.yaml"
+FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-2u/config.json"
+FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-4u/config.json"
+FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,rainier-1s4u/config.json"
+FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-fan-presence/presence/ibm,everest/config.json"