meta-openembedded: subtree update:01d539b324..fd1a0c9210
Adrian Bunk (1):
xmlrpc-c: Remove the RDEPENDS on perl
Denys Dmytriyenko (1):
mariadb: update SRC_URI to use archive.mariadb.org
Khem Raj (7):
xorg-fonts-100dpi: Change License Custom -> MIT
fio: Depend on coreutils-native for fmt utility
fio: Fix build when march is armv7ve
pmdk: Update to 1.7
README: Document need for 32bit compiler
mongodb: Turn system libpcre support into packageconfig
grpc: Update to 1.24.1
Otavio Salvador (1):
modemmanager: Upgrade 1.10.2 -> 1.10.6
Palmer Dabbelt (1):
Add zeus compatibility to all layer.conf files
Peiran Hong (1):
tcpdump: upgrade 4.9.2 -> 4.9.3
Stefan Agner (1):
zram: properly implement systemd service
Stefan Wiehler (1):
nvme-cli: upgrade 1.6 -> 1.9
Trevor Gamblin (2):
gnome-desktop3: upgrade from 3.32.0 to 3.34.0
freeradius: add -latomic for armv5
William A. Kennington III via Openembedded-devel (1):
log4cpp: Stop using RC as a variable
Change-Id: I9b3bd69a061da11a59d38bce42543cb090b24601
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-networking/recipes-devtools/grpc/grpc_1.24.1.bb b/meta-openembedded/meta-networking/recipes-devtools/grpc/grpc_1.24.1.bb
new file mode 100644
index 0000000..5cfa3aa
--- /dev/null
+++ b/meta-openembedded/meta-networking/recipes-devtools/grpc/grpc_1.24.1.bb
@@ -0,0 +1,49 @@
+DESCRIPTION = "A high performance, open source, general-purpose RPC framework. \
+Provides gRPC libraries for multiple languages written on top of shared C core library \
+(C++, Node.js, Python, Ruby, Objective-C, PHP, C#)"
+HOMEPAGE = "https://github.com/grpc/grpc"
+SECTION = "libs"
+LICENSE = "Apache-2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS = "gflags c-ares protobuf protobuf-native protobuf-c protobuf-c-native openssl"
+DEPENDS_append_class-target = " googletest grpc-native "
+DEPENDS_append_class-nativesdk = " grpc-native "
+
+S = "${WORKDIR}/git"
+SRCREV_grpc = "fe494ff4104b6f6a78117ab2da71d29c93053267"
+SRCREV_upb = "9effcbcb27f0a665f9f345030188c0b291e32482"
+BRANCH = "v1.24.x"
+SRC_URI = "git://github.com/grpc/grpc.git;protocol=https;name=grpc;branch=${BRANCH} \
+ git://github.com/protocolbuffers/upb;name=upb;destsuffix=git/third_party/upb \
+ file://0001-CMakeLists.txt-Fix-libraries-installation-for-Linux.patch \
+ "
+SRC_URI_append_class-target = " file://0001-CMakeLists.txt-Fix-grpc_cpp_plugin-path-during-cross.patch \
+ "
+SRC_URI_append_class-nativesdk = " file://0001-CMakeLists.txt-Fix-grpc_cpp_plugin-path-during-cross.patch"
+
+# Fixes build with older compilers 4.8 especially on ubuntu 14.04
+CXXFLAGS_append_class-native = " -Wl,--no-as-needed"
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE = " \
+ -DgRPC_CARES_PROVIDER=package \
+ -DgRPC_ZLIB_PROVIDER=package \
+ -DgRPC_SSL_PROVIDER=package \
+ -DgRPC_PROTOBUF_PROVIDER=package \
+ -DgRPC_GFLAGS_PROVIDER=package \
+ -DgRPC_INSTALL=ON \
+ -DCMAKE_CROSSCOMPILING=ON \
+ -DBUILD_SHARED_LIBS=ON \
+ "
+
+do_configure_prepend_mipsarch() {
+ sed -i -e "s/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} rt m pthread)/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} atomic rt m pthread)/g" ${S}/CMakeLists.txt
+}
+
+BBCLASSEXTEND = "native nativesdk"
+
+SYSROOT_DIRS_BLACKLIST_append_class-target = "${libdir}/cmake/grpc"
+
+FILES_${PN}-dev += "${bindir}"