meta-openembedded: subtree update:509d40153d..1e8bc46e55
Adrian Bunk (5):
networkmanager: musl now supports secure_getenv
libuser: musl now supports secure_getenv
libgit2: Upgrade 0.27.8 -> 0.27.9
poppler: Stop using USE_FIXEDPOINT
networkmanager: Upgrade 1.18.0 -> 1.18.2
Andreas Müller (10):
xfce4-time-out-plugin: upgrade 1.0.2 -> 1.0.3
xfce4-battery-plugin: 1.1.2 -> 1.1.3
xfce4-smartbookmark-plugin: upgrade 0.5.0 -> 0.5.1
xfce4-wavelan-plugin: upgrade 0.6.0 -> 0.6.1
xfce4-netload-plugin: upgrade 1.3.1 -> 1.3.2
xfce4-systemload-plugin: upgrade 1.2.2 -> 1.2.3
xfce4-mpc-plugin: upgrade 0.5.1 -> 0.5.2
xfce4-fsguard-plugin: upgrade 1.1.0 -> 1.1.1
xfce4-diskperf-plugin: upgrade 2.6.1 -> 2.6.2
gigolo: upgrade 0.4.2 -> 0.5.0
Anuj Mittal (2):
clinfo: add recipe
ade: add recipe
Hongxu Jia (1):
lvm2: fix circular dependencies while systemd enable cryptsetup
Jan Kaisrlik (1):
networkd-dispatcher: service file is using different location of binary
Johannes Pointner (1):
libtinyxml2: update to 7.1.0
Martin Jansa (1):
python-socketio: prevent python2 socketio depending on python3-aiohttp
Piotr Tworek (3):
libgee: Update to version 0.20.2
gnome-bluetooth: Update to version 3.32.1.
gnome-keyring: Update to version 3.28.2
Yi Zhao (1):
apache2: upgrade 2.4.39 -> 2.4.41
Yuan Chao (5):
libnftnl: upgrade 1.1.3 -> 1.1.4
libtdb: upgrade 1.4.0 -> 1.4.1
python-flask-pymongo: upgrade 0.5.1 -> 2.3.0
xfsprogs: upgrade 5.2.0 -> 5.2.1
python-protobuf: upgrade 3.9.0 -> 3.9.1
Zang Ruochen (1):
cryptsetup: upgrade 2.1.0 -> 2.2.0.
Change-Id: I4db480893fc3b39cc7e014dbca0adc9c5317abf1
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.1.bb b/meta-openembedded/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.1.bb
new file mode 100644
index 0000000..bed80a6
--- /dev/null
+++ b/meta-openembedded/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_5.2.1.bb
@@ -0,0 +1,73 @@
+SUMMARY = "XFS Filesystem Utilities"
+HOMEPAGE = "http://oss.sgi.com/projects/xfs"
+SECTION = "base"
+LICENSE = "GPLv2 & LGPLv2.1"
+LICENSE_libhandle = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=74274e8a218423e49eefdea80bc55038 \
+ file://LICENSES/LGPL-2.1;md5=b370887980db5dd40659b50909238dbd"
+DEPENDS = "util-linux util-linux-native"
+SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsprogs/${BP}.tar.xz \
+ file://remove_flags_from_build_flags.patch \
+ file://0001-build-Check-for-sync_file_range-libc-function.patch \
+ file://0001-Check-for-MAP_SYNC-in-sys-mman.h.patch \
+ file://0002-include-include-xfs-linux.h-after-sys-mman.h.patch \
+ "
+SRC_URI[md5sum] = "5ca3f79e76e3fb984a03d1b42a2e60ba"
+SRC_URI[sha256sum] = "7b500e148cebd08f99e37cf744c7843817b37e7be2a32c4dc57d6ea16e3019ae"
+
+inherit autotools-brokensep
+
+PACKAGES =+ "${PN}-fsck ${PN}-mkfs ${PN}-repair libhandle"
+
+DEPENDS += "util-linux"
+
+RDEPENDS_${PN} = "${PN}-fsck ${PN}-mkfs ${PN}-repair"
+
+FILES_${PN}-fsck = "${base_sbindir}/fsck.xfs"
+FILES_${PN}-mkfs = "${base_sbindir}/mkfs.xfs"
+FILES_${PN}-repair = "${base_sbindir}/xfs_repair"
+
+FILES_libhandle = "${base_libdir}/libhandle${SOLIBS}"
+
+EXTRA_OECONF = "--enable-gettext=no \
+ --enable-scrub=no \
+ INSTALL_USER=root \
+ INSTALL_GROUP=root \
+ ac_cv_header_aio_h=yes \
+ ac_cv_lib_rt_lio_listio=yes \
+"
+
+DISABLE_STATIC = ""
+EXTRA_AUTORECONF += "-I ${S}/m4 --exclude=autoheader"
+
+PACKAGECONFIG ??= "readline blkid"
+
+PACKAGECONFIG[readline] = "--enable-readline=yes,--enable-readline=no,readline"
+PACKAGECONFIG[blkid] = "--enable-blkid=yes,--enable-blkid=no,util-linux"
+
+export DEBUG="-DNDEBUG"
+export BUILD_VERBOSE="1"
+export tagname="CC"
+
+EXTRA_OEMAKE = "DIST_ROOT='${D}'"
+
+do_configure () {
+ export BUILD_CC="${BUILD_CC} ${BUILD_CFLAGS}"
+ # Prevent Makefile from calling configure without arguments,
+ # when do_configure gets called for a second time.
+ rm -f ${B}/include/builddefs ${B}/include/platform_defs.h ${B}/configure
+ # Recreate configure script.
+ oe_runmake configure
+ install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
+ install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
+ oe_runconf
+}
+
+do_install_append() {
+ oe_runmake 'DESTDIR=${D}' install-dev
+ rm ${D}${libdir}/*.la
+ rmdir --ignore-fail-on-non-empty ${D}${libdir}
+
+ ln -sf -r ${D}${libdir}/libhandle.a ${D}${base_libdir}/libhandle.a
+ ln -sf -r ${D}${base_libdir}/libhandle.so ${D}${libdir}/libhandle.so
+}