meta-openembedded: subtree update:1bfaa2e63a..64224b92e5
Adrian Bunk (1):
networkmanager: Upgrade 1.18.2 -> 1.18.4
Alistair Francis (5):
mycroft: Bump to 19.8.1
mycroft: Run the files from /var
python3-monotonic: Initial commit of version 1.5
python3-msk: Initial commit of version 0.3.13
python3-google-api-python-client: Initial commit of 1.7.11
Andreas Müller (3):
exiv2: initial add 0.27.1
menulibre: upgrade 2.2.0 -> 2.2.1
libmbim: upgrade 1.18.0 -> 1.20.0
Callaghan, Dan (1):
strongswan: add a PACKAGECONFIG for libbfd stack traces
Changqing Li (1):
kea: fix kea-dhcp4.service/kea-dhcp6.service start up failed
Christophe PRIOUZEAU (14):
xfce4-mpc-plugin: Clarify BSD license variant
xfce4-diskperf-plugin: Clarify BSD license variant
xfce4-wavelan-plugin: Clarify BSD license variant
libmpdclient: Clarify BSD license variant
tremor: Clarify BSD license variant
xscreensaver: Clarify BSD license variant
openjpeg: Clarify BSD license variant
sdparm: Clarify BSD license variant
onig: Clarify BSD license variant
libssh2: Clarify BSD license variant
libsmi: Clarify BSD license variant
libinih: Clarify BSD license variant
gperftools: Clarify BSD license variant
daemonize: Clarify BSD license variant
Fabio Berton (1):
ifplugd: Add recipe for version 0.28
George Kiagiadakis (1):
pipewire: Initial add of 0.2.7
Hongxu Jia (1):
lvm2/libdevmapper: 2.03.02 -> 2.03.05
Khem Raj (4):
wvstreams,wvdial: Mark incompatible for musl
pidgin-sipe: Upgrade to 1.25.0
dconf: Upgrade to 0.34.0
libsmi: Fix and operator per SPDX
Martin Siegumfeldt (3):
Revert "libiio: fix build of python bindins"
libiio: allow python3 bindings to be built
libiio: bump to version 0.18+
Stefan Wiehler (1):
nvme-cli: defer host ID generation to post installation
Tekkub (1):
nlohmann-fifo: Add recipe
Trevor Gamblin (2):
rsyslog: fix CVE-2019-17041
quagga: fix PIDFile path for service files
Yi Zhao (2):
freeradius: fix CVE-2019-10143
ipvsadm: install initscript to /etc/init.d
Zang Ruochen (9):
python-paste: upgrade 3.2.1 -> 3.2.2
python-pip: upgrade 19.2.3 -> 19.3
python-pyasn1-modules: upgrade 0.2.6 -> 0.2.7
python-pytest: upgrade 5.1.3 -> 5.2.1
python-pytz: upgrade 2019.2 -> 2019.3
python-xxhash: upgrade 1.4.1 -> 1.4.2
python-cffi: upgrade 1.12.3 -> 1.13.0
python-jsonschema: upgrade 3.0.2 -> 3.1.1
protobuf: upgrade 3.9.2 -> 3.10.0
Change-Id: I72806dd6bfe6427787917f687d058c6ced02a00c
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-devtools/nlohmann-fifo/nlohmann-fifo_git.bb b/meta-openembedded/meta-oe/recipes-devtools/nlohmann-fifo/nlohmann-fifo_git.bb
new file mode 100644
index 0000000..326a4ab
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-devtools/nlohmann-fifo/nlohmann-fifo_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "fifo maps for c++"
+HOMEPAGE = "https://github.com/nlohmann/fifo_map"
+SECTION = "libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.MIT;md5=b67209a1e36b682a8226de19d265b1e0"
+
+SRC_URI = "git://github.com/nlohmann/fifo_map.git"
+
+PV = "1.0.0+git${SRCPV}"
+
+SRCREV = "0dfbf5dacbb15a32c43f912a7e66a54aae39d0f9"
+
+S = "${WORKDIR}/git"
+
+# nlohmann-fifo is a header only C++ library, so the main package will be empty.
+
+RDEPENDS_${PN}-dev = ""
+
+BBCLASSEXTEND = "native nativesdk"
+
+do_install() {
+ install -d ${D}${includedir}
+ install -m 0644 ${S}/src/fifo_map.hpp ${D}${includedir}
+}