meta-openembedded: subtree update:1bfaa2e63a..64224b92e5
Adrian Bunk (1):
networkmanager: Upgrade 1.18.2 -> 1.18.4
Alistair Francis (5):
mycroft: Bump to 19.8.1
mycroft: Run the files from /var
python3-monotonic: Initial commit of version 1.5
python3-msk: Initial commit of version 0.3.13
python3-google-api-python-client: Initial commit of 1.7.11
Andreas Müller (3):
exiv2: initial add 0.27.1
menulibre: upgrade 2.2.0 -> 2.2.1
libmbim: upgrade 1.18.0 -> 1.20.0
Callaghan, Dan (1):
strongswan: add a PACKAGECONFIG for libbfd stack traces
Changqing Li (1):
kea: fix kea-dhcp4.service/kea-dhcp6.service start up failed
Christophe PRIOUZEAU (14):
xfce4-mpc-plugin: Clarify BSD license variant
xfce4-diskperf-plugin: Clarify BSD license variant
xfce4-wavelan-plugin: Clarify BSD license variant
libmpdclient: Clarify BSD license variant
tremor: Clarify BSD license variant
xscreensaver: Clarify BSD license variant
openjpeg: Clarify BSD license variant
sdparm: Clarify BSD license variant
onig: Clarify BSD license variant
libssh2: Clarify BSD license variant
libsmi: Clarify BSD license variant
libinih: Clarify BSD license variant
gperftools: Clarify BSD license variant
daemonize: Clarify BSD license variant
Fabio Berton (1):
ifplugd: Add recipe for version 0.28
George Kiagiadakis (1):
pipewire: Initial add of 0.2.7
Hongxu Jia (1):
lvm2/libdevmapper: 2.03.02 -> 2.03.05
Khem Raj (4):
wvstreams,wvdial: Mark incompatible for musl
pidgin-sipe: Upgrade to 1.25.0
dconf: Upgrade to 0.34.0
libsmi: Fix and operator per SPDX
Martin Siegumfeldt (3):
Revert "libiio: fix build of python bindins"
libiio: allow python3 bindings to be built
libiio: bump to version 0.18+
Stefan Wiehler (1):
nvme-cli: defer host ID generation to post installation
Tekkub (1):
nlohmann-fifo: Add recipe
Trevor Gamblin (2):
rsyslog: fix CVE-2019-17041
quagga: fix PIDFile path for service files
Yi Zhao (2):
freeradius: fix CVE-2019-10143
ipvsadm: install initscript to /etc/init.d
Zang Ruochen (9):
python-paste: upgrade 3.2.1 -> 3.2.2
python-pip: upgrade 19.2.3 -> 19.3
python-pyasn1-modules: upgrade 0.2.6 -> 0.2.7
python-pytest: upgrade 5.1.3 -> 5.2.1
python-pytz: upgrade 2019.2 -> 2019.3
python-xxhash: upgrade 1.4.1 -> 1.4.2
python-cffi: upgrade 1.12.3 -> 1.13.0
python-jsonschema: upgrade 3.0.2 -> 3.1.1
protobuf: upgrade 3.9.2 -> 3.10.0
Change-Id: I72806dd6bfe6427787917f687d058c6ced02a00c
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf_3.10.0.bb b/meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf_3.10.0.bb
new file mode 100644
index 0000000..9284541
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf_3.10.0.bb
@@ -0,0 +1,90 @@
+SUMMARY = "Protocol Buffers - structured data serialisation mechanism"
+DESCRIPTION = "Protocol Buffers are a way of encoding structured data in an \
+efficient yet extensible format. Google uses Protocol Buffers for almost \
+all of its internal RPC protocols and file formats."
+HOMEPAGE = "https://github.com/google/protobuf"
+SECTION = "console/tools"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=37b5762e07f0af8c74ce80a8bda4266b"
+
+DEPENDS = "zlib"
+DEPENDS_append_class-target = " protobuf-native"
+
+SRCREV = "6d4e7fd7966c989e38024a8ea693db83758944f1"
+
+SRC_URI = "git://github.com/google/protobuf.git;branch=3.10.x \
+ file://run-ptest \
+ file://0001-protobuf-fix-configure-error.patch \
+ file://0001-Makefile.am-include-descriptor.cc-when-building-libp.patch \
+ file://0001-examples-Makefile-respect-CXX-LDFLAGS-variables-fix-.patch \
+"
+S = "${WORKDIR}/git"
+
+inherit autotools-brokensep pkgconfig ptest
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[python] = ",,"
+
+EXTRA_OECONF += "--with-protoc=echo"
+
+TEST_SRC_DIR = "examples"
+LANG_SUPPORT = "cpp ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}"
+
+do_compile_ptest() {
+ mkdir -p "${B}/${TEST_SRC_DIR}"
+
+ # Add the location of the cross-compiled header and library files
+ # which haven't been installed yet.
+ cp "${B}/protobuf.pc" "${B}/${TEST_SRC_DIR}/protobuf.pc"
+ sed -e 's|libdir=|libdir=${PKG_CONFIG_SYSROOT_DIR}|' -i "${B}/${TEST_SRC_DIR}/protobuf.pc"
+ sed -e 's|Cflags:|Cflags: -I${S}/src|' -i "${B}/${TEST_SRC_DIR}/protobuf.pc"
+ sed -e 's|Libs:|Libs: -L${B}/src/.libs|' -i "${B}/${TEST_SRC_DIR}/protobuf.pc"
+ export PKG_CONFIG_PATH="${B}/${TEST_SRC_DIR}"
+
+ # Save the pkgcfg sysroot variable, and update it to nothing so
+ # that it doesn't append the sysroot to the beginning of paths.
+ # The header and library files aren't installed to the target
+ # system yet. So the absolute paths were specified above.
+ save_pkg_config_sysroot_dir=$PKG_CONFIG_SYSROOT_DIR
+ export PKG_CONFIG_SYSROOT_DIR=
+
+ # Compile the tests
+ for lang in ${LANG_SUPPORT}; do
+ oe_runmake -C "${S}/${TEST_SRC_DIR}" ${lang}
+ done
+
+ # Restore the pkgconfig sysroot variable
+ export PKG_CONFIG_SYSROOT_DIR=$save_pkg_config_sysroot_dir
+}
+
+do_install_ptest() {
+ local olddir=`pwd`
+
+ cd "${S}/${TEST_SRC_DIR}"
+ install -d "${D}/${PTEST_PATH}"
+ for i in add_person* list_people*; do
+ if [ -x "$i" ]; then
+ install "$i" "${D}/${PTEST_PATH}"
+ fi
+ done
+ cp "${S}/${TEST_SRC_DIR}/addressbook_pb2.py" "${D}/${PTEST_PATH}"
+ cd "$olddir"
+}
+
+PACKAGE_BEFORE_PN = "${PN}-compiler ${PN}-lite"
+
+FILES_${PN}-compiler = "${bindir} ${libdir}/libprotoc${SOLIBS}"
+FILES_${PN}-lite = "${libdir}/libprotobuf-lite${SOLIBS}"
+
+RDEPENDS_${PN}-compiler = "${PN}"
+RDEPENDS_${PN}-dev += "${PN}-compiler"
+RDEPENDS_${PN}-ptest = "bash ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python-protobuf', '', d)}"
+
+MIPS_INSTRUCTION_SET = "mips"
+
+BBCLASSEXTEND = "native nativesdk"
+
+LDFLAGS_append_arm = " -latomic"
+LDFLAGS_append_mips = " -latomic"
+LDFLAGS_append_powerpc = " -latomic"
+LDFLAGS_append_mipsel = " -latomic"