nicole: Add LED support

Changed to be consistent with the schematics.

(From meta-yadro rev: 19d9cb67b24396fabbe7160a3f04a71d775c166c)

Signed-off-by: Artem Senichev <a.senichev@yadro.com>
Change-Id: I46a3f1dde090bd247ddbf72a3a0c1310d6fafdd2
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-yadro/meta-nicole/recipes-phosphor/leds/nicole-led-manager-config-native.bb b/meta-yadro/meta-nicole/recipes-phosphor/leds/nicole-led-manager-config-native.bb
new file mode 100644
index 0000000..da34c8b
--- /dev/null
+++ b/meta-yadro/meta-nicole/recipes-phosphor/leds/nicole-led-manager-config-native.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Phosphor LED Group Management for Nicole"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit native
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+SRC_URI += "file://led.yaml"
+
+S = "${WORKDIR}"
+
+do_install() {
+    SRC=${S}
+    DEST=${D}${datadir}/phosphor-led-manager
+    install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}