poky: sumo refresh d240b885f2..eebbc00b25
Update poky to sumo HEAD.
Anuj Mittal (1):
perl: skip tests that are not useful
Armin Kuster (4):
tzcode-native: updatet to 2018e
tzdata: update to 2018e
tzcode: update to 2018f
tzdata: update to 2018f
Bruce Ashfield (10):
kernel-yocto/cfg: configuration warning fixes
linux-yocto/4.14/4.18: address kernel configuration warnings
linux-yocto: configuration warning fixes
linux-yocto: tweak RTC configuration
linux-yocto/4.14: fix kernel configuration audit warnings
linux-yocto/4.14: update to v4.14.71
linux-yocto: enable pci and CRYPTO_DEV_VIRTIO
linux-yocto/4.14: fix beaglebone configuration warnings
linux-yocto-rt: fixup 4.14 merge issues
linux-yocto/4.14: update to v4.14.76
Changqing Li (1):
apt: update SRC_URI
Chen Qi (2):
python: backport patch to fix CVE-2018-1000802
python: backport patch to fix CVE-2018-14647
Dan McGregor (2):
os-release: move to nonarch_libdir
base-files: change permissions on /sys and /proc
Derek Straka (1):
python: update to version 2.7.15
Grygorii Tertychnyi (2):
cve-check: Allow multiple entries in CVE_PRODUCT
curl: extend CVE_PRODUCT
Hongxu Jia (2):
valgrind: fix compile ptest failure on mips32
nasm: fix CVE-2018-1000667
Hongzhi.Song (1):
linux-yocto-rt: Add paravirt_kvm support for qemux86-64
Jagadeesh Krishnanjanappa (1):
valgrind: fix ptest compilation for PowerPC64
Peter Kjellerstedt (1):
curl: Include the complete license information
Richard Purdie (2):
yocto-uninative: Upgrade to verson 2.3 which includes glibc 2.28
oeqa/selftest/runtime_test: Ensure we build/use gnupg-native
Ross Burton (2):
python: clean up ptest
python: don't use runtime checks to identify float endianism
Zhixiong Chi (1):
curl: CVE-2018-14618
Change-Id: I4b7aa481ed2a57c3551c4a45d30350f2376444cc
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/poky/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb b/poky/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb
index d5b285e..d6d37ed 100644
--- a/poky/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb
+++ b/poky/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb
@@ -11,13 +11,13 @@
raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "af1b926c9160b0dbf2bbe41b166a8a7b07191fd2"
-SRCREV_meta ?= "c43c9e19a22367b48c0f62764c8555643d2a6844"
+SRCREV_machine ?= "eafe398ca1404953c2a01559c83d3a983f8717b1"
+SRCREV_meta ?= "3435617380af107e31ec4e36173b9cf1f8a371a0"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.14;destsuffix=${KMETA}"
-LINUX_VERSION ?= "4.14.67"
+LINUX_VERSION ?= "4.14.76"
DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
DEPENDS += "openssl-native util-linux-native"
@@ -38,4 +38,4 @@
KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
KERNEL_FEATURES_append_qemuall=" cfg/virtio.scc"
KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
-KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"
+KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"