meta-fii/meta-kudo: add misc configuration

1. add the hotswap-power-cycle
2. add the entity-association-map
3. add the phosphor-ipmi-blobs-binarystore

Signed-off-by: Lancelot Kao <lancelot.kao@fii-usa.com>
Change-Id: Ieea8f21a35c81ed066eedab0c8264494b743f3bb
Signed-off-by: Mohaimen Alsamarai <mohaimen.alsamarai@fii-na.com>
diff --git a/meta-fii/meta-kudo/recipes-kudo/kudo-system/kudo-entity-association-map.bb b/meta-fii/meta-kudo/recipes-kudo/kudo-system/kudo-entity-association-map.bb
new file mode 100644
index 0000000..85006da
--- /dev/null
+++ b/meta-fii/meta-kudo/recipes-kudo/kudo-system/kudo-entity-association-map.bb
@@ -0,0 +1,16 @@
+UMMARY = "Kudo IPMI Entity association mapping."
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI += "file://kudo_entity_association_map.json"
+
+FILES_${PN} = " \
+    ${datadir}/ipmi-entity-association/entity_association_map.json \
+    "
+
+do_install() {
+    install -d ${D}${datadir}/ipmi-entity-association
+    install -m 0644 -D ${WORKDIR}/kudo_entity_association_map.json \
+        ${D}${datadir}/ipmi-entity-association/entity_association_map.json
+}