meta-openembedded: subtree update:466fd78ac6..41fe46157c

Callaghan, Dan (2):
      firewalld: add UPSTREAM_CHECK_URI
      add new recipes for python-lrparsing, python3-lrparsing

Khem Raj (2):
      mongodb: Remove non building arches from COMPATIBLE_HOST
      uim: Fix cross-builds

Martin Jansa (1):
      libmicrohttpd: backport the fix for building with older gnutls

Oleksandr Kravchuk (4):
      libyui: update to 3.6.0
      libyui-ncurses: udpate to 2.52.0
      sanlock: update to 3.6.0
      tesseract-lang: update to 4.0.0

Randy MacLeod (1):
      crash: update from 7.2.6 to 7.2.7

Robert Yang (8):
      python-asn1crypto: extend to nativesdk
      python-incremental: Drop broken nativesdk
      fuse: Fix installed-vs-shipped for nativesdk
      keyutils: Fix installed-vs-shipped for nativesdk
      libnet-ssleay-perl: Drop broken native
      libnet-dns-sec-perl: Drop broken native
      iperf3: Drop broken native
      spice: Drop broken native

Trevor Gamblin (1):
      haveged: upgrade v1.9.4 -> v1.9.6

Zang Ruochen (5):
      xterm: upgrade 348 -> 349
      python-cmd2: upgrade 0.9.16 -> 0.9.17
      python-protobuf: upgrade 3.9.1 -> 3.9.2
      python-alembic: upgrade 1.2.0 -> 1.2.1
      python-paste: upgrade 3.2.0 -> 3.2.1

Change-Id: I4491ea47f5e54f4f3843a77c720d0a89304c36a5
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses_2.52.0.bb b/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses_2.52.0.bb
new file mode 100644
index 0000000..dae5c34
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-graphics/libyui/libyui-ncurses_2.52.0.bb
@@ -0,0 +1,48 @@
+SUMMARY = "Character Based User Interface for libyui"
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
+    file://COPYING.lgpl-2.1;md5=4fbd65380cdd255951079008b364516c \
+"
+
+SRC_URI = "git://github.com/libyui/libyui-ncurses.git \
+           file://0003-Simplify-ncurses-finding-module.patch \
+          "
+
+SRC_URI_append_class-target = " file://0001-Fix-the-error-of-can-t-find-header-file.patch"
+
+SRCREV = "d5b64b6291b6f292871ad5c6df25c4f6896f7d50"
+
+S = "${WORKDIR}/git"
+
+inherit cmake gettext pkgconfig
+
+DEPENDS += "boost libyui ncurses"
+
+BBCLASSEXTEND = "nativesdk"
+
+do_configure_prepend () {
+    cd ${S}
+    git checkout bootstrap.sh
+    sed -i "s#/usr#${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" bootstrap.sh
+    ./bootstrap.sh
+    mkdir -p ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib64/
+    cp ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib/libyui.so* ${PKG_CONFIG_SYSROOT_DIR}${base_prefix}/usr/lib64/
+    cd -
+    sed -i -e "s#\${YPREFIX}#\${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${S}/CMakeLists.txt
+    sed -i -e "s#/usr#${PKG_CONFIG_SYSROOT_DIR}${base_prefix}&#" ${PKG_CONFIG_SYSROOT_DIR}${libdir}/cmake/libyui/LibyuiLibraryDepends-release.cmake
+}
+
+do_install_append () {
+    if [ "${libdir}" = "${base_prefix}/usr/lib" ] && [ -d ${D}/usr/lib64 ]; then
+        mv ${D}/usr/lib64 ${D}/usr/lib
+    fi
+}
+
+do_install_append_class-nativesdk () {
+    mkdir -p ${D}/${base_prefix}
+    mv ${D}/usr ${D}/${base_prefix}
+}
+
+FILES_${PN} += "${datadir}/*"
+
+FILES_${PN}-dev += "${libdir}/*"