meta-ufispace: Add meta-ufispace layer and meta-ncplite machine

Iniitial submission of meta-layer and meta-machine layer.

Tested: Build and run on our machine successfully.

Change-Id: I4920d8ce6aff119ba5cbc4772d84a6377784f85d
Signed-off-by: Jordan Chang <jordan.chang@ufispace.com>
diff --git a/meta-ufispace/meta-ncplite/recipes-ncplite/ncplite-inventory-log/ncplite-inventory-log.bb b/meta-ufispace/meta-ncplite/recipes-ncplite/ncplite-inventory-log/ncplite-inventory-log.bb
new file mode 100644
index 0000000..43d2c05
--- /dev/null
+++ b/meta-ufispace/meta-ncplite/recipes-ncplite/ncplite-inventory-log/ncplite-inventory-log.bb
@@ -0,0 +1,25 @@
+SUMMARY = "OpenBMC NCPLite Check Inventory State Service"
+DESCRIPTION = "OpenBMC NCPLite Check Inventory State Daemon."
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit systemd
+
+DEPENDS += "systemd"
+RDEPENDS:${PN} += "bash"
+
+SRC_URI = " file://inventory-log.sh \
+            file://inventory-log.service \
+          "
+
+do_install() {
+    install -d ${D}${libexecdir}/${BPN}
+    install -m 0755 ${WORKDIR}/inventory-log.sh ${D}${libexecdir}/${BPN}
+
+    install -d ${D}${systemd_system_unitdir}
+    install -m 0644 ${WORKDIR}/inventory-log.service ${D}${systemd_system_unitdir}
+}
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE:${PN} = "inventory-log.service"