meta-openembedded: subtree update:a2928764c2..19528ba2a6

Adrian Bunk (1):
      libqmi: Replace clang patch with configure option

Bartosz Golaszewski (3):
      yad: new package
      zenity: new package
      unclutter-xfixes: new package

Khem Raj (2):
      mycroft: Remove alsa-oss from rdeps
      bigbuckbunny: Use faster download mirrors

Oleksandr Kravchuk (21):
      capnproto: update to 0.7.0
      ddrescue: update to 1.24
      fmt: update to 6.0.0
      jsonrpc: update to 1.2.0
      libburn: update to 1.5.0
      libdvdread: update to 6.0.1
      libev: update to 4.27
      libmodplug: update to 0.8.9.0
      libnice: update to 0.1.16
      libopus: update to 1.3.1
      libsass: update to 3.6.1
      libuv: update to 1.32.0
      libsocketcan: update to 0.0.11
      tree: update to 1.8.0
      xclock: update to 1.0.9
      xcursorgen: update to 1.0.7
      xfontsel: update to 1.0.6
      xmag: update to 1.0.6
      xmessage: update to 1.0.5
      xorg-sgml-doctools: update to 1.11
      evtest: update to 1.34

Peiran Hong (1):
      tcpdump: Fix CVE-2017-16808

Change-Id: I4f2f575382cd34404d10470ece0aae7620487902
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-multimedia/libmodplug/libmodplug_0.8.9.0.bb b/meta-openembedded/meta-oe/recipes-multimedia/libmodplug/libmodplug_0.8.9.0.bb
new file mode 100644
index 0000000..398daae
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-multimedia/libmodplug/libmodplug_0.8.9.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Library for reading mod-like audio files"
+HOMEPAGE = "http://modplug-xmms.sf.net"
+
+LICENSE = "PD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=c9182faa1f7c316f7b97d404bcbe3685"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/modplug-xmms/libmodplug-${PV}.tar.gz"
+SRC_URI[md5sum] = "5ba16981e6515975e9a68a58d5ba69d1"
+SRC_URI[sha256sum] = "457ca5a6c179656d66c01505c0d95fafaead4329b9dbaa0f997d00a3508ad9de"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-option-checking"
+
+# NOTE: autotools_stage_all does nothing here, we need to do it manually
+do_install_append() {
+    install -d ${D}${includedir}/libmodplug
+    install -m 0644 ${S}/src/modplug.h ${D}${includedir}/libmodplug
+    install -m 0644 ${S}/src/modplug.h ${D}${includedir}/
+}