Add default cs_privilege_levels.json config file

As part of below patch, adding default Cipher Suite Privilege Levels
config file i.e. cs_privilege_levels.json to /usr/share/ipmi-providers/

https://gerrit.openbmc-project.xyz/#/c/openbmc/phosphor-host-ipmid/
  +/21500/

IPMI Spec 13.17 provides a way to pick a "highest level matching
proposed algorithms" during RMCPP Open Session Request, and effective
privilege levels are decided taking Cipher Suite Privilege Levels into
account. This patch initializes Cipher Suite Privilege Levels
configurations into a JSON file. By default, admin privileges are
given to all Cipher Suites across all channels.

(From meta-phosphor rev: 21aff89f885f061a75b26bc09164fdc44a1a749f)

Signed-off-by: jayaprakash Mutyala <mutyalax.jayaprakash@intel.com>
Change-Id: I66ca032b0c040e8f6055b83044320f85b6fb2ef1
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
index 8de43d2..2d8b491 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
@@ -14,6 +14,7 @@
     file://channel_access.json \
     file://channel_config.json \
     file://entity-map.json \
+    file://cs_privilege_levels.json \
     "
 
 FILES_${PN} = " \
@@ -25,6 +26,7 @@
     ${datadir}/ipmi-providers/channel_access.json \
     ${datadir}/ipmi-providers/channel_config.json \
     ${datadir}/ipmi-providers/entity-map.json \
+    ${datadir}/ipmi-providers/cs_privilege_levels.json \
     "
 
 do_fetch[noexec] = "1"
@@ -50,4 +52,6 @@
         ${D}${datadir}/ipmi-providers/channel_config.json
     install -m 0644 -D ${WORKDIR}/entity-map.json \
         ${D}${datadir}/ipmi-providers/entity-map.json
+    install -m 0644 -D ${WORKDIR}/cs_privilege_levels.json \
+        ${D}${datadir}/ipmi-providers/cs_privilege_levels.json
 }