libfastjson: backport patch to fix compilation error

I've met the following compilation error.

  | ../git/json_object.c:415:3: error: jump skips variable initialization [-Werror=jump-misses-init]

Backport a patch to fix it.

(From meta-openembedded rev: a74abf155d7bd6c873fd72b76369c09e5c68031c)

Change-Id: I90a18e76838721cf8a77c7def0ee08e9e40c8359
Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-extended/rsyslog/libfastjson_0.99.8.bb b/meta-openembedded/meta-oe/recipes-extended/rsyslog/libfastjson_0.99.8.bb
index ea089de..b84dde3 100644
--- a/meta-openembedded/meta-oe/recipes-extended/rsyslog/libfastjson_0.99.8.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/rsyslog/libfastjson_0.99.8.bb
@@ -6,7 +6,8 @@
 
 DEPENDS = ""
 
-SRC_URI = "git://github.com/rsyslog/libfastjson.git;protocol=https"
+SRC_URI = "git://github.com/rsyslog/libfastjson.git;protocol=https \
+           file://0001-fix-jump-misses-init-gcc-8-warning.patch"
 
 SRCREV = "4758b1caf69ada911ef79e1d80793fe489b98dff"