meta-phosphor: ipmi-config: add default entity map
Add an empty entity map json file. The file is expected to be an array,
if it is present at all. The file provided by default has no real
meaning to your system, therefore you are expected if you use the entity
records, to provide one for your system.
See: https://github.com/openbmc/phosphor-host-ipmid/blob/master/scripts/entity-example.md
for details on how it should be formatted.
Currently formatted:
[{
"id": 1,
# Container entity contains other entities
# Entity Id and entity Instance for the container entity
"containerEntityId": 13,
"containerEntityInstance": 81,
# A record can have contained entities as a four entry list or as upto
# two ranges of entity instances; this record has contained entities
# as a four entry list
"isList": true,
# Records can be linked if necessary to extend the number of contained
# entities within a container entity; this record is not linked
"isLinked": false,
"entities": [
{"entityId1": 10, "entityInstance1": 1},
{"entityId2": 10, "entityInstance2": 3},
{"entityId3": 10, "entityInstance3": 5},
{"entityId4": 10, "entityInstance4": 7}
]
}]
(From meta-phosphor rev: 34d8886d6642eb0b991b696f4d28950c5bec9bf5)
Signed-off-by: Patrick Venture <venture@google.com>
Change-Id: I00956c92d444ac82d4a9aabfd33c26ccbb58e145
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
index 02a7c64..8de43d2 100644
--- a/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
+++ b/meta-phosphor/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
@@ -13,6 +13,7 @@
file://power_reading.json \
file://channel_access.json \
file://channel_config.json \
+ file://entity-map.json \
"
FILES_${PN} = " \
@@ -23,6 +24,7 @@
${datadir}/ipmi-providers/power_reading.json \
${datadir}/ipmi-providers/channel_access.json \
${datadir}/ipmi-providers/channel_config.json \
+ ${datadir}/ipmi-providers/entity-map.json \
"
do_fetch[noexec] = "1"
@@ -46,5 +48,6 @@
${D}${datadir}/ipmi-providers/channel_access.json
install -m 0644 -D ${WORKDIR}/channel_config.json \
${D}${datadir}/ipmi-providers/channel_config.json
-
+ install -m 0644 -D ${WORKDIR}/entity-map.json \
+ ${D}${datadir}/ipmi-providers/entity-map.json
}