Support uploading multiple certificates per authority service

Since the certificate manager can support multiple certificates
the CERTPATH for mode=authentication will be changed to directory.

This change depends on anothere review, see Depends-On tag.

Becase the TrustStore will be used by TLS authentication,
any operation on certificates should result in bmcweb restart, that
is why #Units to restart entry is added.

Since update procedure will not replace configuration file in /etc
all configuration files for the certificate-manager will be deployed
in /usr/share/phosphor-certificate-manager.

(From meta-phosphor rev: 0c09ff71d089c614b14d076d933e849f2f74281e)

Signed-off-by: Zbigniew Kurzynski <zbigniew.kurzynski@intel.com>
Change-Id: Ib7f4ba60760ab8cd1ac647bc51dadf50af7fedc7
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config.bb b/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config.bb
index 0a53a32..5b0c03a 100644
--- a/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config.bb
+++ b/meta-phosphor/recipes-phosphor/certificate/phosphor-nslcd-cert-config.bb
@@ -11,8 +11,10 @@
 
 SRC_URI = "file://env"
 
+FILES_${PN} = "${datadir}"
+
 do_install() {
-	install -D ${WORKDIR}/env ${D}/${sysconfdir}/default/obmc/cert/nslcd
+	install -D ${WORKDIR}/env ${D}/${datadir}/phosphor-certificate-manager/nslcd
 }
 
 pkg_postinst_${PN}() {