meta-openembedded: subtree update:53d431639a..e4ac09169d
Andreas Müller (9):
file-roller: add gsettings to inherit
tracker: add gsettings to inherit
nautilus: add gsettings to inherit
libgweather: add gsetings & upstream-version-is-even to inherit
gnome-settings-daemon: add gsettings to inherit
gnome-terminal: add gsettings to inherit
parole: upgrade 1.0.4 -> 1.0.5
exo: upgrade 0.12.8 -> 0.12.9
gedit: add gsettings to inherit
Changqing Li (1):
dnsmasq.conf: fix dnsmasq path
Denys Dmytriyenko (1):
recipes: rename distro_features_check to features_check
Jan Luebbe (6):
openct: merge do_install and do_install_append
pcsc-lite: add support for native builds
opensc: use pcsc-lite instead of openct by default
opensc: add support for native builds
libp11: add support for native builds
softhsm: add recipe
Kai Kang (1):
mariadb: replace dependency readline with libedit
Khem Raj (6):
dlm: Drop -fstack-clash-protection for clang
ruli: Fix install step and build samples too
libkcapi: Update patch to upstream submitted one
sanlock: Use python3 and add sanlock user/group
sanlock: Replace cp -a with cp -R --no-dereference
nodejs: libatomic patch should be target specific
Lei YU (1):
googletest: move to release 1.10.0
Nicola Lunghi (4):
python3-importlib-metadata: fix class-target overriding default dependencies
python-configparser: Add native and nativesdk to BBCLASSEXTEND
python-contextlib2: Add native and nativesdk to BBCLASSEXTEND
python-scandir: Add native and nativesdk to BBCLASSEXTEND
Paul Barker (1):
liblockfile: Rename patch
Qi.Chen@windriver.com (1):
python-jsonschema: add missing dependency
Ross Burton (1):
python-babel: add BBCLASSEXTEND for native/nativesdk
Rouven Czerwinski (1):
python-pyelftools: add recipes
Stefan Agner (2):
haveged: use the Fedora service file available from upstream
networkmanager: do not deploy unnecessary udev rule file
Wang Mingyu (3):
mcelog: upgrade 1.65 -> 1.66
hwdata: upgrade 0.328 -> 0.329
libdev-checklib-perl: upgrade 1.13 -> 1.14
Zang Ruochen (17):
python-zopeinterface: upgrade 4.6.0 -> 4.7.1
python-yappi: upgrade 0.98 -> 1.0
python-xstatic: upgrade 1.0.1 -> 1.0.2
python-xlrd: upgrade 1.1.0 -> 1.2.0
python-urllib3: upgrade 1.25.6 -> 1.25.7
python-tzlocal: upgrade 1.5.1 -> 2.0.0
python-twitter: upgrade 3.7.0 -> 3.8.0
python-twisted: upgrade 19.7.0 -> 19.10.0
python3-meh: upgrade 0.47 -> 0.48
python-pyephem: upgrade 3.7.6.0 -> 3.7.7.0
python3-pykickstart: upgrade 3.20 -> 3.22
python-pyparted: upgrade 3.11.2 -> 3.11.3
libextutils-cppguess-perl: upgrade 0.12 -> 0.20
libmoo-perl: upgrade 2.003004 -> 2.003006
libdbd-sqlite-perl: upgrade 1.62 -> 1.64
libclass-method-modifiers-perl: upgrade 2.12 -> 2.13
librole-tiny-perl: upgrade 2.000006 -> 2.001004
niko.mauno@vaisala.com (2):
gitpkgv.bbclass: Use --git-dir option
gitpkgv.bbclass: Support also lightweight tags
Change-Id: I00fb24df7bb3849ed0c9337a66623d9b4cba5999
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-openembedded/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.25.bb b/meta-openembedded/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.25.bb
index a87c228..6869e2c 100644
--- a/meta-openembedded/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.25.bb
+++ b/meta-openembedded/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.25.bb
@@ -9,7 +9,6 @@
LICENSE_${PN}-spy = "GPLv3+"
LICENSE_${PN}-spy-dev = "GPLv3+"
LIC_FILES_CHKSUM = "file://COPYING;md5=628c01ba985ecfa21677f5ee2d5202f6"
-DEPENDS = "udev"
SRC_URI = "https://pcsclite.apdu.fr/files/${BP}.tar.bz2"
SRC_URI[md5sum] = "c20650a36062ab1689f37f3302c988f2"
@@ -19,19 +18,21 @@
EXTRA_OECONF = " \
--disable-libusb \
- --enable-libudev \
--enable-usbdropdir=${libdir}/pcsc/drivers \
"
S = "${WORKDIR}/pcsc-lite-${PV}"
-PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} udev"
+PACKAGECONFIG_class-native ??= ""
PACKAGECONFIG[systemd] = ",--disable-libsystemd,systemd,"
+PACKAGECONFIG[udev] = "--enable-libudev,--disable-libudev,udev"
PACKAGES = "${PN} ${PN}-dbg ${PN}-dev ${PN}-lib ${PN}-doc ${PN}-spy ${PN}-spy-dev"
RRECOMMENDS_${PN} = "ccid"
+RRECOMMENDS_${PN}_class-native = ""
FILES_${PN} = "${sbindir}/pcscd"
FILES_${PN}-lib = "${libdir}/libpcsclite*${SOLIBS}"
@@ -50,3 +51,5 @@
RCONFLICTS_${PN} += "${PN}-systemd"
SYSTEMD_SERVICE_${PN} = "pcscd.socket"
RDEPENDS_${PN}-spy +="python"
+
+BBCLASSEXTEND = "native"