romulus: Remove avbus-workaround
This was a workaround for DD1 (pre-production) hardware.
Jordan Keuseman <jkeusema@us.ibm.com> wrote:
> That was an issue back in DD1 time frame where the VRM needed to
> change their signal voltage thresholds for AVS bus to work around a
> problem where the processor was putting out a runt pulse in the final
> bit of the transaction. They fixed that in the silicon so we got rid
> of the work around.
This was removed from Witherspoon when dropping DD1 support from
OpenBMC. We can remove it from Romulus and other platforms too.
(From meta-ibm rev: baedc91099960c0e582a98e465e190ff9c3aa9cc)
Change-Id: I8266c154505d3b4fb268cd7c44aa84f5a4be0301
Signed-off-by: Joel Stanley <joel@jms.id.au>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb b/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb
index e014da2..252d2cb 100644
--- a/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb
+++ b/meta-ibm/meta-romulus/recipes-phosphor/chassis/avsbus-control.bb
@@ -7,14 +7,11 @@
RDEPENDS_${PN} += "i2c-tools bash"
S = "${WORKDIR}"
-SRC_URI += "file://avsbus-workaround.sh \
- file://avsbus-enable.sh \
+SRC_URI += "file://avsbus-enable.sh \
file://avsbus-disable.sh"
do_install() {
install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}/avsbus-workaround.sh \
- ${D}${bindir}/avsbus-workaround.sh
install -m 0755 ${WORKDIR}/avsbus-disable.sh \
${D}${bindir}/avsbus-disable.sh
install -m 0755 ${WORKDIR}/avsbus-enable.sh \
@@ -23,18 +20,13 @@
TMPL_EN= "avsbus-enable@.service"
TMPL_DIS= "avsbus-disable@.service"
-TMPL_WA= "avsbus-workaround@.service"
INSTFMT_EN= "avsbus-enable@{0}.service"
INSTFMT_DIS= "avsbus-disable@{0}.service"
-INSTFMT_WA= "avsbus-workaround@{0}.service"
TGTFMT = "obmc-chassis-poweron@{0}.target"
FMT_EN = "../${TMPL_EN}:${TGTFMT}.requires/${INSTFMT_EN}"
FMT_DIS = "../${TMPL_DIS}:${TGTFMT}.requires/${INSTFMT_DIS}"
-FMT_WA = "../${TMPL_WA}:${TGTFMT}.requires/${INSTFMT_WA}"
SYSTEMD_SERVICE_${PN} += "${TMPL_EN}"
SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_EN', 'OBMC_CHASSIS_INSTANCES')}"
SYSTEMD_SERVICE_${PN} += "${TMPL_DIS}"
SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_DIS', 'OBMC_CHASSIS_INSTANCES')}"
-SYSTEMD_SERVICE_${PN} += "${TMPL_WA}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_WA', 'OBMC_CHASSIS_INSTANCES')}"