treewide: clean up recipe checks in OBMC_MACHINE_FEATURES

OBMC_MACHINE_FEATURES is a variable that probably shouldn't even exist
as all it does is provide a level of indirection to the real
MACHINE_FEATURES (in phosphor-base.inc, OBMC_ is added to the base).
There are a few recipes that have developed checks against
OBMC_MACHINE_FEATURES for enabling recipe-level features when they
should be checking the standard MACHINE_FEATURES variable.  Clean up
this recipe-level indirection.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Id437b93aa6c1de9a27726eea9b7e2c30e71ab3bf
diff --git a/meta-ibm/recipes-phosphor/logging/phosphor-logging_%.bbappend b/meta-ibm/recipes-phosphor/logging/phosphor-logging_%.bbappend
index 3614174..aa69617 100644
--- a/meta-ibm/recipes-phosphor/logging/phosphor-logging_%.bbappend
+++ b/meta-ibm/recipes-phosphor/logging/phosphor-logging_%.bbappend
@@ -11,7 +11,7 @@
 FILES:${PN}:append:p10bmc = " ${datadir}/phosphor-logging/pels/ibm,everest_dev_callouts.json"
 
 #Enable phal feature, if available.
-PACKAGECONFIG:append = " ${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}"
+PACKAGECONFIG:append = " ${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}"
 PACKAGECONFIG[phal] = "-Dphal=enabled, -Dphal=disabled, pdata libekb pdbg"
 
 do_install:append:p10bmc() {