treewide: clean up recipe checks in OBMC_MACHINE_FEATURES
OBMC_MACHINE_FEATURES is a variable that probably shouldn't even exist
as all it does is provide a level of indirection to the real
MACHINE_FEATURES (in phosphor-base.inc, OBMC_ is added to the base).
There are a few recipes that have developed checks against
OBMC_MACHINE_FEATURES for enabling recipe-level features when they
should be checking the standard MACHINE_FEATURES variable. Clean up
this recipe-level indirection.
Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: Id437b93aa6c1de9a27726eea9b7e2c30e71ab3bf
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index 8cedb62..f3c63ad 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -48,7 +48,7 @@
ln -s $TARGET $LINK
# Only install certain units if phal enabled
- if [ "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" = phal ]; then
+ if [ "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}" = phal ]; then
mkdir -p $D$systemd_system_unitdir/obmc-host-start@0.target.requires
LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service"
TARGET="../phal-reinit-devtree.service"
@@ -115,7 +115,7 @@
rm $LINK
# Remove phal specific units if enabled
- if [ "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" = phal ]; then
+ if [ "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}" = phal ]; then
LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service"
rm $LINK