Fix MRW native installs paths
How it was before could cause problems in Jenkins.
Change-Id: I33cf31fc79c995b4609f77eeac1896d3812d276b
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb b/meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb
index ec1df89..01bff61 100644
--- a/meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb
+++ b/meta-phosphor/common/recipes-phosphor/mrw/mrw-api-native.bb
@@ -15,6 +15,6 @@
SRCREV = "04f15f37e9ab6c09412a0abcffb87e9aefcc5368"
do_install() {
- install -d ${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw
- install -m 0755 Targets.pm ${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw/Targets.pm
+ install -d ${D}${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw
+ install -m 0755 Targets.pm ${D}${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw/Targets.pm
}